Plesk and AWStats

Hi all,

We've got a Windows 2003 Server running Plesk 7.6

Everything works fine until you decide to look at the stats for the website.

The stats open up fine, but when you want to look at some further information i.e. a Full list of the referring Search Terms, or the Entry & exit pages, a pop up appears, which is good, but then we get a 403 Forbidden Error

I've Googled, checked the SWSoft website, checked most websites in fact, so thought I would come to my favourite place.

What do you need to know to fix my problem ?

I thought it was permissions based, so for a test, I assigned Everyone with Full Control rights, including rights to files and subdirectories, but I still got the 403 forbidden error

Anyone got any suggestions ?

cheers
Si
LVL 16
legalsrlAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
Sam PanwarConnect With a Mentor Sr. Server AdministratorCommented:
Hi,

Yes these days the most popular control panel are.

Linux :

cpanel : end user
WHM  : reseller / admin

Window

Helm control panel.

The Awstats is working fine with the all above control panel and I not recomand another control panel.  If you getting problem with the Awstats then you have another option  smarter stats for stats. its free for one domain and it is advance then the Awstst, check it.

http://www.smartertools.com/Products/SmarterStats/Default.aspx
0
 
Sam PanwarSr. Server AdministratorCommented:
Hi legalsr,


IF you are getting 403 forbidden error then the main reason of it is :

Reason : This status code indicates that the client has sent bad data or a malformed request to the server. Client errors are generally issued by the webserver when a client tries to gain access to a protected area using a bad username and password.

Solution :

Check the IIS setting for log files
check the logs file format  is correct
you have already create DATA folder in the Awstats

OR check your installtion from the following steps.

1.    Download the Latest version of Awstats from following url: (http://awstats.sourceforge.net/)
2.    Install the Awstats using Downloaded Installer. (Recommended path is c:\Awstats).
3.    Create a Directory with the name of Data at c:\Awstats.
4.    Make the configuration of log format in IIS (Windows 2003) IIS>web site>properties>website tab>Active Log format>properties>Advanced Tab.
5.    Create a virtual directory in IIS through which you can view the Awstats through Helm CP or directly by url like (http://IPAddress/awstats/cgi-bin/awstats.pl?config=domainname.com), we preferred that create virtual directory under Helm CP website in IIS.
6.    Add update. bat file in the schedule task, update. bat will be available in 'C:\Awstats\wwwroot\cgi-bin', it will be daily process the log files and update the stats.


OTHER reason:

1. Microsoft say about this error :
Although the error message indicates that there is an incorrect default Web site, this issue occurs because the Internet Server Application Programming Interface (ISAPI) filter for Exchfilt.dll either is not loaded or is not working properly.

2 Are you using any firewall please check if you stop any popup for awstats.

3. Check folder and file permissions of Awsats then check server setup.


-ABS
0
Get 10% Off Your First Squarespace Website

Ready to showcase your work, publish content or promote your business online? With Squarespace’s award-winning templates and 24/7 customer service, getting started is simple. Head to Squarespace.com and use offer code ‘EXPERTS’ to get 10% off your first purchase.

 
legalsrlAuthor Commented:
Hi Abs,

Thanks for that.....

I can get the stats pages to appear fine with all the relevent information on them....it's just when I try to find more information out i.e. if I want to know all the entry/exit pages, not just the top 10 then it gives me the error.

I found the more detailed pages are being created as I found them in the vhosts/statistics/plesk-stat/webstat directory so I can go on to them individually and look at them, but it doesn't like something.

I'll check the firewall, but I think it's all done at the router......

I'm not sure it's permissions as as a test I created a dummy domain and gave everyone Full control permissions manually (not through plesk)

I'll have a play and get back to you

Thanks again
Si
0
 
legalsrlAuthor Commented:
Also, just to add....

I've turned off popup blocker - no difference
I've add the domain to the trusted sites - no difference

Have noticed also that if I click on Update Now on the page, I also get the 403 error

Cheers
Si
0
 
Sam PanwarSr. Server AdministratorCommented:
Hi legalsrl,

Have you select all logs format in the IIS ???

-ABS
0
 
legalsrlAuthor Commented:
abs,

It seems to be a problem with Plesk.

They seem to just want to give you the basic information and you have to do more if you want more....

I've spent hours arguing with their Tech Support that their product is not up to scratch, but they say they have customers who are happy with it.

So go......**** themselves.....

Anyway, thanks for the help, I'm never touching plesk again.......I'd rather do it manually unless you have any other suggestions apart from cpanel or something like that

What do you use ?

cheers
Si
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.