Solved

Outgoing mail for certain domains stuck on qmail queue

Posted on 2006-11-28
16
4,177 Views
Last Modified: 2009-12-16
Hey everyone. I've seen a few cases where mail going to certain domains just sits in the queue.

I was trying to send email to someone (not a local address) who i have sent mail to from a different server. Multiple attempts just won't go out to that domain for some reason

I just sent out a newsletter blast to my clients. All 300 messages went out accept for 2. I know the email addresses exist so I cant figure out why they get stuck.

I'm running Plesk 8.0.1 and have researched on the plesk forum and tried this recommendation with no results.
http://forum.swsoft.com/showthread.php?s=&threadid=33366

Is there something that I can do? a DNS setting? a qmail setting? an MX setting? rDNS setting? SPF?

Any help would be appreciated.

Thanks

Fish
><>
0
Comment
Question by:fishtank22
  • 8
  • 6
16 Comments
 
LVL 14

Expert Comment

by:pablouruguay
ID: 18036208
what is the error in your /var/log/maillog for this mails?
0
 

Author Comment

by:fishtank22
ID: 18037863
/var/log/maillog is empty. I believe PLESK writes to /usr/local/psa/var/maillog

But what I'm seeing when the error happens is something like below... but why would this only happen on some domains? The messages have since gone out. I had server issues and had to restart the server a few times. When I checked the queue it was empty. (So I guess they went out)

Nov 28 16:38:06 23426434 qmail: 1164749886.365314 delivery 52: deferral: Sorry,_I_wasn't_able_to_establish_an_SMTP_connection._(#4.4.1)/
Nov 28 16:38:06 23426434 qmail: 1164749886.365581 status: local 0/80 remote 6/80
Nov 28 16:38:06 23426434 qmail: 1164749886.407585 delivery 49: deferral: Sorry,_I_wasn't_able_to_establish_an_SMTP_connection._(#4.4.1)/
Nov 28 16:38:06 23426434 qmail: 1164749886.407861 status: local 0/80 remote 5/80
Nov 28 16:38:07 23426434 qmail: 1164749887.182779 delivery 53: success: 66.196.97.250_accepted_message./Remote_host_said:_250_ok_dirdel/
Nov 28 16:38:07 23426434 qmail: 1164749887.183072 status: local 0/80 remote 4/80
Nov 28 16:38:07 23426434 qmail: 1164749887.183269 end msg 16869288
Nov 28 16:38:07 23426434 qmail: 1164749887.524794 delivery 51: success: 209.191.88.247_accepted_message./Remote_host_said:_250_ok_dirdel/
Nov 28 16:38:07 23426434 qmail: 1164749887.525062 status: local 0/80 remote 3/80
Nov 28 16:38:07 23426434 qmail: 1164749887.525258 end msg 16778459
Nov 28 16:38:07 23426434 qmail: 1164749887.526123 delivery 50: deferral: TLS_connect_failed:_error:140920F8:SSL_routines:SSL3_GET_SERVER_HELLO:unknown_cipher_returnedZConnected_to_67.139.134.238_but_connection_died._error:140920F8:SSL_routines:SSL3_GET_SERVER_HELLO:unknown_cipher_returned_(#4.4.2)/
Nov 28 16:38:07 23426434 qmail: 1164749887.526381 status: local 0/80 remote 2/80
Nov 28 16:38:07 23426434 qmail: 1164749887.612445 delivery 54: deferral: TLS_connect_failed:_error:0D07209B:asn1_encoding_routines:ASN1_get_object:too_longZConnected_to_67.139.134.238_but_connection_died._error:0D07209B:asn1_encoding_routines:ASN1_get_object:too_long_(#4.4.2)/
0
 
LVL 14

Expert Comment

by:pablouruguay
ID: 18038321
0
 
LVL 14

Expert Comment

by:pablouruguay
ID: 18038366
0
 

Author Comment

by:fishtank22
ID: 18038478
Hey Pablo, thanks again. Unfortunately, I'm aware of both of those posts but they are very different from my situation. Those posts discuss all outgoing mail being stuck in the queue. My problem is that all mail is going out accept for a few domains which seem to be getting stuck. Though If I email these people from a different SMTP server, like gmail, it reaches them.

See what I'm saying? I can't seem to find a case where someone else is having this problem.

regards

Dave
0
 
LVL 14

Expert Comment

by:pablouruguay
ID: 18039312
just a question... what is the size of your mail? because you have this
SN1_get_object:too_long_

i think you have a parameter in smtp to limit of message.
0
 

Author Comment

by:fishtank22
ID: 18039334
The mail file was a fairly simple multipart HTML email with a 250k attachement.
0
VMware Disaster Recovery and Data Protection

In this expert guide, you’ll learn about the components of a Modern Data Center. You will use cases for the value-added capabilities of Veeam®, including combining backup and replication for VMware disaster recovery and using replication for data center migration.

 
LVL 14

Expert Comment

by:pablouruguay
ID: 18039407
is too extrange.. try to make a

telnet domainreject 25

and paste the result please
0
 

Author Comment

by:fishtank22
ID: 18039447
Sorry, You mean SSH into the box and run that command?

telnet domainreject 25

when I do I get:
telnet: domainreject: Name or service not known
domainreject: Unknown host

so maybe you mean something else? or should I put in my domain or IP or something somewhere?

Thanks
0
 
LVL 14

Expert Comment

by:pablouruguay
ID: 18039528
no no no jejejejejej replace domainreject with the name of the from: domain name for example my mail is pablo@allietti.com you need to do

telnet allietti.com 25

;)
0
 

Author Comment

by:fishtank22
ID: 18039624
OHHHHH!!!!!! Sorry. I'm a little slow today.

So i tried 4 different domains:
I found that 3 of them were all on the same providers server

Connected to domain.com.
Escape character is '^]'.
220 o13.hostbaby.com ESMTP

another 3 others resonded with:
220 o11.hostbaby.com ESMTP

intersting....

and one other was
machine:~ $ telnet qwestmp.com 25
Trying 216.160.44.169...
telnet: connect to address 216.160.44.169: Operation timed out
telnet: Unable to connect to remote host
0
 
LVL 14

Accepted Solution

by:
pablouruguay earned 150 total points
ID: 18039745
ok. maybe ... just maybe  hostbaby use a blacklist or something like this to block some ips... and your ip maybe is in the list.

the second server qwestmp.com didnt response... simple.

maybe your server works perfect..... try to send me an e-mail to pablo@allietti.com
0
 

Author Comment

by:fishtank22
ID: 18045978
hmmm. well I know for a fact that there are many other hostbaby messages that made it out of the queue. So I don't believe I'm blacklisted.
Aa for the Qwest email. I guess is a dead email or something.

Has anyone else out there seen this happen? Would there be any other reason why certain emails would get stuck. Even if I delete that stuck message and send it again. it gets stuck.

Thanks
0
 
LVL 14

Expert Comment

by:pablouruguay
ID: 18046263
ok. try to send me an e-mail..  

2. maybe this people use greylist and you dont have a correct MX or DNS records
0

Featured Post

Give your grad a cloud of their own!

With up to 8TB of storage, give your favorite graduate their own personal cloud to centralize all their photos, videos and music in one safe place. They can save, sync and share all their stuff, and automatic photo backup helps free up space on their smartphone and tablet.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Proxy with authentication for internet access 5 107
Error when calling SSH command 20 108
IPA client Config problems 2 167
What are recommended OS for exim mail server? 10 101
I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
Video by: Mark
This lesson goes over how to construct ordered and unordered lists and how to create hyperlinks.
As a trusted technology advisor to your customers you are likely getting the daily question of, ‘should I put this in the cloud?’ As customer demands for cloud services increases, companies will see a shift from traditional buying patterns to new…

895 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now