Computer not picking up IP from DHCP Server

Hi, Having a problem with 2 comptuers on a network.  They won't pick up an ip address from the dhcp server.  The other 40 computers and few printers on the network are fine.  
Insteady it picks up some strange IP address and a different subnet mask and says the connection has limited connectivity.

Any Ideas?

Also I put in a manual details for the IP Address, Subnet Mask and Default Gateway but it displays as connected to the network but still can't connect to the internet.
LVL 3
harris9999Asked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
Fatal_ExceptionConnect With a Mentor Commented:
Please post the strange IPAddress information (ipconfig /all) here so we can get a feel for what you are seeing...

Also, if you are running SP2 on these, issue this command to reset the Winsock Stack:  netsh catalog reset

And, although it is improbable that 2 systems NICs could go bad at once, and if you have a spare NIC around, you might try replacing it..

FE
0
 
Drizzt420Connect With a Mentor Commented:
Try running this little utility on the troubled machines:

http://www.snapfiles.com/get/winsockxpfix.html
0
 
Toni UranjekConsultant/TrainerCommented:
Probably your computer assigns itself APIPA address: 169.254.x.y./16
If you want to access Internet when you enter IP settings manually you need to set Prefered DNS server IP number also.

Check your DHCP server if pool of addresses is not exhausted, and if it's not check DHCP log (%systemroot%\system32\dhcp) to find out why lease is not granted, or worse not even offered.
0
 
harris9999Author Commented:
Strange one this.  Onve machine the winsockfixxp fix by Drizzt420 solved the problem.  

The second it didn;t work on it. So tried the reset the Winsock Stack:  netsh catalog reset and when it done that it picked up an ip from the dhcp server, but wasn't geting any internet , although a ping worked the odd time, so tried a usb ethernet adaptor to test the network card and that solved the problem.  

Thanks Guys
0
 
Fatal_ExceptionCommented:
:)  just glad you got it working!  and thank you..

FE
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.