Solved

Problem with Offline use

Posted on 2006-11-29
15
2,743 Views
Last Modified: 2010-03-18
This problem is very complicated and long so please ask any necessary questions if you do not fully understand.

Computer freezes when users use Offline files.

We are experiencing a problem with some of our hp laptops (3 x nc6230, 1 x nc6110). We have over 80 laptops working fine with offline files (mix of Acer and hp)

They work perfectly when connected to the network, but when a user takes their laptop home (after making their documents ‘available offline’) the computer hangs and eventually stops responding altogether.

There are no ‘events’ of consequence in the logs except on one laptop I had the following message:

Event Type:      Warning
Event Source:      PlugPlayManager
Event Category:      None
Event ID:            257
Date:            28/11/2006
Time:            21:43:05
User:            N/A
Computer:      HPLAP15
Description:
Timed out sending notification of target device change to window of "C:\WINDOWS\Explorer.EXE"

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

Microsoft article suggested I upgrade to a newer version of the file!

A few days ago we had suspected a virus infection on our network so I turned on ‘Sophos On-access’ scanning. These problems have started since this change. But changing it back has not solved the issue.

The four users are in 3 different OU’s (in ADUC) with different GPO’s attached to them but only minor differences so I suspect this is not the cause.

Below I will itemise the steps I have already taken to try and sort this problem.

•      Changed Sophos On-access to off
•      Added two of the users to be part of the ‘local administrators’ group (the other two were already part of the group on their respective laptops).
•      ‘re-imaged’ one laptop and created a new roaming profile for this user computer.
•      Re installed Sophos manually
•      Check articles:
o      www.experts-exchange.com/Q_21616257 (no applicable solution)
o      www.experts-exchange.com/Q_20816307 
All affected users use BT Broadband at home so this might have something to do with it.

While investigating I managed to replicate this problem when loading a ‘word’ document (IT Problems.doc). Windows crashed I rebooted and while trying to synchronise on next logon I got the following error.

“Offline Files (\\server\username$ on server): Access to ‘~$ Problems.doc’ is denied on \\server\username$\My Documents”

Then ran full check on HDD for viruses and got the following errors in the Client Side Cache.

•         Scanning “C:\Windows\CSC\d2\80001659” returned SAV Interface error 0xa004021a: Sophos Anti-Virus could not proceed, the file was corrupted.

•         Scanning “C:\Windows\CSC\d2\80001B49” returned SAV Interface error 0xa004021a: Sophos Anti-Virus could not proceed, the file was corrupted.


•         Scanning “C:\Windows\CSC\d2\8000165B” returned SAV Interface error 0xa004021a: Sophos Anti-Virus could not proceed, the file was corrupted.

•         Scanning “C:\Windows\CSC\d2\8000165D” returned SAV Interface error 0xa0040212: The file is encrypted

I usually do not get any CSC based errors when running a virus check
 
Any input or help would be greatly received.
0
Comment
Question by:Jiberoony
15 Comments
 
LVL 66

Accepted Solution

by:
johnb6767 earned 500 total points
ID: 18037902
The CSC is the Offline Store for those files. I would try and reinitialize the Offline Files Database....

How to re-initialize the offline files cache and database
http://support.microsoft.com/kb/230738

The database looks corrupted. Keep in mind, this will wipe out all temp versiosn of offline files, so if there are offline files still waiting to be kept on the server, copy them manually for now....

0
 

Author Comment

by:Jiberoony
ID: 18044003
After refreshing the CSC (which would have happened with the re-image) I am still getting the same problem, however I am now getting the message.


“Offline Files (\\server\username$ on server): Access to ‘~$ Problems.doc’ is denied on \\server\username$\My Documents”

“Offline Files (\\server\username$ on server): Unable to merge offline changes on ‘\\server\username$.’ Access is denied.”

I have now removed all MS Word temp files (i.e. ~$*.doc)

The synchronise now shows no errors.

Problem still exists
0
 
LVL 66

Expert Comment

by:johnb6767
ID: 18045357
For the user that you are synchronizing, is \\server\username$ thier folder, or possibly another users, that they dont have access to?
0
Ransomware-A Revenue Bonanza for Service Providers

Ransomware – malware that gets on your customers’ computers, encrypts their data, and extorts a hefty ransom for the decryption keys – is a surging new threat.  The purpose of this eBook is to educate the reader about ransomware attacks.

 
LVL 66

Expert Comment

by:johnb6767
ID: 18045442
Reinitializing the cache usually does resolve db errors in the CSC store.....And usually Access denied errors arre from other peoples cached files trying to synch, whne the current user logs into the laptop...

If 5 people log into teh laptop, and all sync thier files, every sync there after will sync all previous users data, unless you specify a primary user...

Files that you add to the Offline Files folder on a Windows XP-based computer are synchronized when another person uses the computer
http://support.microsoft.com/?kbid=811660.

mainly, "Purge files for non-primary users at logoff"
0
 

Author Comment

by:Jiberoony
ID: 18045882
Sorry probably not clear in the original post.

All users have thier own laptops.

and the path that is being synchronised is thier 'home Folder' the example I have is "\\win2k3pdc\AHinchliff$\My Documents\IT Problems"

the crash occurs even if a new document is created.

I am begining to think that this is an office / offline problem only however it only seems to be happening on our hp laptops. We are experiencing this on 5 out of 16 hp laptops and none of our 78 Acer laptops!!
0
 

Author Comment

by:Jiberoony
ID: 18052538
NEW INFORMATION:

I have now noticed that the computer only seems to crash when trying to save Office documents into an offline folder (i.e. the CSC).

If I save from other programs (Adobe, Macromedia, Serif, Paint) then it saves fine every thing is peachy, also everything goes OK when I try and save an Office document to the HDD or a memorystick.

This points more towards a problem with Office & CSC than the CSC itself!

Thanks for your help so far.
0
 

Author Comment

by:Jiberoony
ID: 18052781
UPDATED INFORMATION:

Crashes only occur with MS WORD and MS PUBLISHER (both 2003) ll other office apps work fine.

and still only experiencing this problem on 4 hp Laptops.
0
 
LVL 66

Expert Comment

by:johnb6767
ID: 18053800
Have you updated MS Office?


"I have now noticed that the computer only seems to crash when trying to save Office documents into an offline folder (i.e. the CSC)."

And silly question....Your not trying to save directly to ...\CSC are you?
0
 

Author Comment

by:Jiberoony
ID: 18053825
Office is up-to-date and although it is a silly question sometimes they need to be asked, users are trying to save to thier 'My Document' folders although saving to another offline folder has the same result. Saving to a 'online' folder (HDD or memorystick) works fine everytime!

0
 

Author Comment

by:Jiberoony
ID: 18067339
Please see other question encase it is related.

http://www.experts-exchange.com/Operating_Systems/WinXP/Q_22081212.html
0
 

Author Comment

by:Jiberoony
ID: 18083897
Problem now solved.

Combination of 2 factors:

Sophos On-Access now contains a tab 'Scan remote files' and we believ this was corrupting the CSC

and

A MS Update cause an syntax error in the System Variable 'Path'
0
 

Author Comment

by:Jiberoony
ID: 18083906
Awarding Points to johnb6767 for only person trying to help.

Thanks John
0
 
LVL 66

Expert Comment

by:johnb6767
ID: 18085117
I wish I could have helped to solve it faster. Good job!!

And thanks!!
0
 

Expert Comment

by:redfoxsupport
ID: 22459001
sorry but can you tell me exactly what was done to resolve this issue as I am experiencing exact same.
Funnily enough we use Sophos aswell but cant find the "Scan remote files" tab in config.
Can someone tell me how locate errors\corruptions in the system variable path and how to I resolve them?  I've looked but I dont know what should look normal.
Any help would be appreciated as this is affecting a couple of directors!!!
0
 

Expert Comment

by:amirson
ID: 27844355


What to do
1.Exclude the folder %systemroot%\csc from on-access scanning.
2.Open Sophos Anti-Virus, select Configure|On-access scanning, and ensure that 'Check files on write' is deselected.

http://www.sophos.com/support/knowledgebase/article/24672.html

0

Featured Post

Simplifying Server Workload Migrations

This use case outlines the migration challenges that organizations face and how the Acronis AnyData Engine supports physical-to-physical (P2P), physical-to-virtual (P2V), virtual to physical (V2P), and cross-virtual (V2V) migration scenarios to address these challenges.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Down grade from Windows 8.1 to 7 NTLDR missing 9 171
RemoteApp Printing 5 101
Installing Windows XP from USB 10 116
Trying to update or install win 7 in a win xp pc 18 118
There are 2 things you must have in order to connect to the internet behind a router, The "Gateway IP" of the router, which is usually something like 192.168.xxx.1, I've seen routers with default values of: 192.168.0.1, 192.168.1.1, 192.168.11.1, …
Step by step guide to Clean and Sort your windows registry! Introduction: Always remember: A Clean registry = Better performance = Save your invaluable time In this article we're going to clear our registry manually! Yes, manually! The e…
Two types of users will appreciate AOMEI Backupper Pro: 1 - Those with PCIe drives (and haven't found cloning software that works on them). 2 - Those who want a fast clone of their boot drive (no re-boots needed) and it can clone your drive wh…
I've attached the XLSM Excel spreadsheet I used in the video and also text files containing the macros used below. https://filedb.experts-exchange.com/incoming/2017/03_w12/1151775/Permutations.txt https://filedb.experts-exchange.com/incoming/201…

840 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question