Solved

sata drive

Posted on 2006-11-29
33
434 Views
Last Modified: 2010-04-25
I just installed a sata drive eliminated my old drive.
i have 1 dvd and cd yet when i boot up it finds 2 of each
i deleted all 4 and they still come back on after reboot.it only happened after i updated my via bus master ide controller-0571  and my via ata controller -3149 and now i also get an icon on the bottom right that says safely remove hard ware.
0
Comment
Question by:billster
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 17
  • 11
  • 4
  • +1
33 Comments
 
LVL 1

Expert Comment

by:rhutzel
ID: 18039613
How is the drive connected to the motherboard, is it connected directly to the motherboard or do you have a pci card?

You could always attempt to install one component at a time.  Obviously starting with the hard drive.  Then the Master Cd/dvd then the cd assuming they are sata.  

Third make sure you are using the latest drivers for the sata device(s).  Sata is an awesome new technology, but can be tricky on older machines.

Ryan
0
 

Author Comment

by:billster
ID: 18041625
i have it connected directly to the motherboard and
the cd and dvd are not sata
0
 
LVL 1

Expert Comment

by:rhutzel
ID: 18042620
Do you have the sata in the 0 or 1 (first sata) socket?
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:billster
ID: 18043115
It is in sata 1 also i have the icon on bottom right of screen for removing my dardware this is not removable its the only hard drive i have.In my screen my Raid is set to non raid yet i just downloaded drivers for raid can this be the problem if so how do i remove all those raid controllers and stuff?
0
 
LVL 3

Expert Comment

by:divdove
ID: 18043222
Have you tryed checking the device manager. have a look see what it has there. There you can maybe uninstall or not.
0
 
LVL 92

Expert Comment

by:nobus
ID: 18043891
>>   when i boot up it finds 2 of each  <<   where are they displayed? in windows, or in the startup list ?
you can go to device manager, view tab> click show hidden devices.
uninstall all CD devices, reboot and test
0
 
LVL 92

Expert Comment

by:nobus
ID: 18043898
...>>I just installed a sata drive eliminated my old drive.   <<   what did you do ? ghiost the old one, or a fresh XP install ?
0
 

Author Comment

by:billster
ID: 18046680
thats where i see the 4 devices in device manager i did an uninstall of all 4 which i only have but on boot up it installs all 4 again. and no no ghost started fresh with xp pro
0
 

Author Comment

by:billster
ID: 18047131
If someone tells me how i can copy and paste my device manager that may help.
0
 
LVL 1

Expert Comment

by:rhutzel
ID: 18047317
If you don't mind me getting back to the statement I said earlier.  Try connecting the hard drive to another sata port and disconnect the cd rom and dvd player altogether and let windows boot.

0
 
LVL 92

Expert Comment

by:nobus
ID: 18047610
go to device manager, view tab, click "show hidden devices" and delete all the disks, except the C:
reboot and test
0
 

Author Comment

by:billster
ID: 18048191
Rhutzel tried that but it woulnt boot
Nobus if i delete every thing will i have a problem with configuring or anything as you can see i'm less than a novice. or e-mail wwerner3@tampabay.rr.com
or call collect 727-938-6208  Thanks guys
0
 

Author Comment

by:billster
ID: 18048255
Problem is even disconnecting the cd and dvd unplugging complete uninstall i booted it up still found 4 devices two secondarys two primarys
0
 
LVL 1

Expert Comment

by:rhutzel
ID: 18048260
I am sorry, I forgot to mention you need to change the boot sequence info in the bios to which sata is the primary.
0
 

Author Comment

by:billster
ID: 18049279
Rhutzel it was set as primary thats what i cant figure out,it also has it set for removable drive thats why i have that stupid icon in the lower right of the screen.I am in florida these guys i went to are worse then me thats scary i dont know where to turn. Thanks Bill
0
 

Author Comment

by:billster
ID: 18049513
Finally got it booted up on 2nd sata all drives disconnected and still picks them up 2 primarys 2 secondarys when i disabled the via serial ata controller-3149 it just picke up the two of them.im thinking im still running this ata raid and i should not be but i just dont know leave it up to you guys.
0
 
LVL 92

Expert Comment

by:nobus
ID: 18052006
>>   if i delete every thing will i have a problem with configuring or anything   <<  no, they reinstall after a reboot.
0
 

Author Comment

by:billster
ID: 18056042
OK last try from begging i changed over to sata
drive thats the only one i have.Fresh install xp pro
(1) dvd (1) cd when i booted up it reads two primary ide and two secondary ide thats in my device manager.Plus like i said before i dont know if that has anything to do with raid or updated drivers i installed,because it does have that icon bottom right screen for safely removing the harddrive i dont  know how it has me with a removable hard drive. well thats it thanks sorry almost impossible for a novice like me to explain to you guys.
0
 
LVL 92

Expert Comment

by:nobus
ID: 18058990
when you installed the new drive, did you do a fresh install of XP ?
and you installed all the drivers for that mobo?
0
 

Author Comment

by:billster
ID: 18060951
Ya i did a fresh xp pro install with my motherboard drivers
0
 
LVL 92

Expert Comment

by:nobus
ID: 18063025
>>  it only happened after i updated my via bus master ide controller-0571  and my via ata controller -3149  <<  can you try a rollback?
0
 

Author Comment

by:billster
ID: 18064441
good idea i'll try that now
0
 

Author Comment

by:billster
ID: 18064512
nobus tried that same thing i just have two disabled now.works fine but thats not the problem the stinking thing is bran new didnt want to disable anything already know what i mean?Thanks man ill stll be waiting for anymore suggestions im only burning up here in florida anyway. Bill
0
 
LVL 92

Expert Comment

by:nobus
ID: 18066852
you did not install any burning software?
Try also connecting only dvd, or only cd. doeas it also happen?
0
 

Author Comment

by:billster
ID: 18071877
No burning software, i disonnected 1 of the drives did the whole restart same thing disconnected both cd and dvd still finds them and installs. and every time i disconnect either one of them when i boot up it not only finds the cd i disconnected but also finds and installs my harddrive seta hell i only have one
0
 

Author Comment

by:billster
ID: 18072063
Also it picks up 2 primarys and 2 secondarys in my device manager under ide /ata/atapi controllers but i disable the two primarys because they show nothing under advanced settings as ultra dma or anything else
0
 
LVL 92

Expert Comment

by:nobus
ID: 18074832
try this : connect the cd drives to the primary
0
 

Author Comment

by:billster
ID: 18079539
ok did that same thing but this time it 1 primary working and 1 secondary working. before it was just to secondarys working.so now i disabled 1 primary 1 secondary. this is really confusing brand new hard drive brand new cd and dvd clean install win xp prof. im lost thanks again nobus please dont give up.LOL
0
 
LVL 92

Expert Comment

by:nobus
ID: 18083232
>>  nobus please dont give up.LOL  <<   don't worry , i'll stay tuned.
what mobo model do you have? and bios version ? maybe we can find something in those corners
0
 

Author Comment

by:billster
ID: 18087296
as rock 775dual-88pr0  bios ami p1.20
0
 
LVL 92

Expert Comment

by:nobus
ID: 18091410
are these the drivers you installed ?  http://www.asrock.com/support/download.asp?Model=775Dual-880Pro
how did you configure the ide devices in thebios? Auto? try setting them to cd (see pg 35 )
http://www.asrock.com/manual/775Dual-880Pro.pdf
0
 

Author Comment

by:billster
ID: 18099401
nobus installed tne new drivers whic were raid,but when the guy installed this sata drive he had non-raid setup in bios now i have raid is that good or bad with sata? next i finally have just 1 primary and 1 secondary GREAT but the 1 pramary current transfer ultra dma mode 4 and current 2.
this is alright but the secondary has no transfer mode primary or secondary.This is all in the device manager under ide/ata/atapi, hen properties advaced settings. curious could you tell me what yours are or the norm? Thanks Mst of it fixed hanks to you.
0
 
LVL 92

Accepted Solution

by:
nobus earned 500 total points
ID: 18099991
>>  now i have raid   <<  if you do not use raid, i would turn it off.
what is connected to the secondary now, and to the primary?
mine are :
primary : DMA if available
secondary : PIO
0

Featured Post

On Demand Webinar: Networking for the Cloud Era

Did you know SD-WANs can improve network connectivity? Check out this webinar to learn how an SD-WAN simplified, one-click tool can help you migrate and manage data in the cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Basic computer tune-up with little or no hardware upgrades. Giving an old computer a tune-up usually results in a minimal performance gain, but a gain nonetheless. Several times a week, I’m faced with users at work who ask to make their computers…
Windows 7 does not have the best desktop search built in. This is something Windows 7 users have struggled with. You type something in, and your search results don’t always match what you are looking for, or it doesn’t actually work at all. There ar…
Finding and deleting duplicate (picture) files can be a time consuming task. My wife and I, our three kids and their families all share one dilemma: Managing our pictures. Between desktops, laptops, phones, tablets, and cameras; over the last decade…
There's a multitude of different network monitoring solutions out there, and you're probably wondering what makes NetCrunch so special. It's completely agentless, but does let you create an agent, if you desire. It offers powerful scalability …
Suggested Courses

630 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question