cannot delete key in loaded hive

I attempted to update some software. It said there is a registry key problem. Went to the software site and found the problem key name. Though my user has admin rights, I could not delete the problem key. Logged in as admin and still could not delete the key. Booted to XP on the backup partition. I have a second install of XP in a small partition to do backups and maintenence on the main install. I loaded the registry from my main system as a hive in the backup system. I still could not delete the problem key, even in a hive, when booted to another system. I have no other problems. Please advise how to delete this bad key. Thanks
dmcdivittAsked:
Who is Participating?
 
DarthModCommented:
Closed, 250 points refunded.
DarthMod
Community Support Moderator
0
 
sirbountyCommented:
Can you shed some light on where it's located?

Try this...
Right-click the key - choose permissions
Click Advanced
Click Add
Type Everyone
Click Full Control
Click OK
Click Replace permission entries on all child objects
Click OK
Click Yes
Click OK

Now, try to delete it.
Post the results.
0
 
dmcdivittAuthor Commented:
It says it's unable to save permission changes, access is denied.

The key appears permanently stuck. I made a reg file and attempted importing, but that doesn't work, either.

The key is HKEY_CLASSES_ROOT\GetRight.Automation . It won't display, either.
0
Cloud Class® Course: Amazon Web Services - Basic

Are you thinking about creating an Amazon Web Services account for your business? Not sure where to start? In this course you’ll get an overview of the history of AWS and take a tour of their user interface.

 
sirbountyCommented:
and from a command-line?

reg query hkcr\GetRight.Automation <Enter>

produces what?

Can you export the key?
0
 
dmcdivittAuthor Commented:
From the command line is says: access is denied.

The key cannot be exported.
0
 
sirbountyCommented:
Try this:

reg query hkcr | find /i "getright" <Enter>

Another thing - applying the permissions, you may need to do it from the parent hive - HKey_Classes_Root - and push the permissions down to all subcontainers...
0
 
dmcdivittAuthor Commented:
This is what the command returned:

HKEY_CLASSES_ROOT\.GetRight
Error:  Access is denied in the key HKEY_CLASSES_ROOT\GetRight.Automation
HKEY_CLASSES_ROOT\GetRight File List
HKEY_CLASSES_ROOT\GetRight.Automation
HKEY_CLASSES_ROOT\Ie2GetRight.Ie2GetRight
HKEY_CLASSES_ROOT\Ie2GetRight.Ie2GetRight.1

I tried changing permission at HKEY_CLASSES_ROOT by editing everyone. Full control was unchecked, then checked again, and apply clicked. Had the hourglass for a few seconds. Still no success in displaying or deleting the problem key.
0
 
sirbountyCommented:
Youch...I'm running out of ideas here... you don't want to fool around too much with the classes root hive, so it's not something that I'd recommend continually testing against without a way out.

Aside from saying you'd need a repair install, restore, or system restore function performed against it, I can't think of anything else that would resolve this for you...sorry... :(

Hopefully someone else has some ideas...
0
 
sirbountyCommented:
Nice one AmigoJack! ;^)
0
 
dmcdivittAuthor Commented:
I tried RegDelNull and it says access denied.
0
 
AmigoJackCommented:
the only thing i found is this :(
http://getright.invisionzone.com/index.php?showtopic=217&pid=4081&st=0&#

bartPE is quite simple and free, but it takes some time to create such a disc. the advantage is that you have an os that can run completely from cd.

very weird indeed :[ i hate hearing you cannot control the registry no matter what. can we really exclude issues like running processes/dlls that can protect the key? maybe getright lets windows load some driver at the startup. have you tried a safeboot?

0
 
dmcdivittAuthor Commented:
I found the reference to bartPE already. Instead of using that I booted to the backup partition and loaded the problem registry as a hive. From there I would have the same capability as any other scheme. But the key still cannot be accessed, displayed, or deleted.

I dumped out the entire registry to a text file. The following is all that references getright.automation:

  [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{4DA2C32A-4195-11D1-A9E1-00403320FCF2}]
  @="GetRight.Automation"

  [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{4DA2C32A-4195-11D1-A9E1-00403320FCF2}\InprocServer32]
  @="C:\\Program Files\\GetRight\\XX2GR.DLL"

  [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{4DA2C32A-4195-11D1-A9E1-00403320FCF2}\ProgId]
  @="GetRight.Automation"

I deleted them. But nothing from HKEY_CLASS_ROOT was written to the text file. I thought everything would be. XX2GR.DLL is given above, so I searched and deleted everything having that, including the key displayed above. When I reboot the key is there again. If I delete the key, how is it reappearing? Is the registry being restored from somewhere?

0
 
dmcdivittAuthor Commented:
I resolved this issue. Can I get credit for it?

The following page has the solution:
http://forum.aumha.org/viewtopic.php?t=8125&sid=03331399bdd9d4348b0e47e864ca5f2a

I will go ahead and post details from the page.

Download SubInACL.exe from here:
http://www.microsoft.com/downloads/details.aspx?FamilyID=e8ba3e56-d8fe-4a91-93cf-ed6985e3927b&displaylang=en

Create the file fix.cmd file where SubInACL.exe was installed. In the file put:
subinacl /subkeyreg HKEY_LOCAL_MACHINE /grant=administrators=f
subinacl /subkeyreg HKEY_CURRENT_USER /grant=administrators=f
subinacl /subkeyreg HKEY_CLASSES_ROOT /grant=administrators=f
subinacl /subdirectories %SystemDrive% /grant=administrators=f
subinacl /subkeyreg HKEY_LOCAL_MACHINE /grant=systems=f
subinacl /subkeyreg HKEY_CURRENT_USER /grant=system=f
subinacl /subkeyreg HKEY_CLASSES_ROOT /grant=system=f
subinacl /subdirectories %SystemDrive% /grant=system=f

Go to cmd prompt. Chaqnge to the directory where SubInACL.exe was installed. Type fix.cmd.

The screen will run for awhile. Don't worry what it says. When it finally comes back to the cmd prompt the bad registry key will be unlocked.
0
 
sirbountyCommented:
Thanx for posting that!  Good info for the future.
Please post for a PAQ/Refund in http:/Community_Support/askQuestion.jsp
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.