Solved

How to start and stop vsftpd service from the command line in Suse Linux 10?

Posted on 2006-11-30
7
8,383 Views
Last Modified: 2013-12-16
Suse Linux doesn't recognise "service vsftpd stop" or "service vsftpd start".  How can I stop/start/restart vsftpd from the command line in Suse Linux 10?  I'm sick of rebooting!!
0
Comment
Question by:Bloodrule
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
  • 2
  • +1
7 Comments
 
LVL 45

Assisted Solution

by:sunnycoder
sunnycoder earned 350 total points
ID: 18044367
Hi Bloodrule,

You can use:
/usr/sbin/vsftpd &
killall vsftpd
to start and stop the server respectively

Also see
http://www.novell.com/coolsolutions/feature/14689.html

Cheers!
sunnycoder
0
 
LVL 10

Expert Comment

by:ssvl
ID: 18044992
This is the proper way to do

/etc/init.d/service stop
                          start
                          status

http://www.oreilly.com/catalog/debian/chapter/book/ch07_03.html
0
 
LVL 10

Assisted Solution

by:ssvl
ssvl earned 100 total points
ID: 18045037
The service command is for redhat Flavors

and the /etc/init.d/servicename start is matched for all linux and unix Flavors
0
NFR key for Veeam Backup for Microsoft Office 365

Veeam is happy to provide a free NFR license (for 1 year, up to 10 users). This license allows for the non‑production use of Veeam Backup for Microsoft Office 365 in your home lab without any feature limitations.

 
LVL 3

Assisted Solution

by:bryanlloydharris
bryanlloydharris earned 50 total points
ID: 18047849
/etc/init.d/vsftpd {start|stop|restart}

Maybe like that?
0
 

Author Comment

by:Bloodrule
ID: 18051286
If I use /usr/sbin/vsftpd & I get a message saying standalone execution is not supported and that I must use xinetd.  Now what should I do?

(To ssvl:

If I follow your steps, namely,

/etc/init.d/service stop
                          start
                          status

I get a "service command not found" or similar message.)
0
 
LVL 45

Accepted Solution

by:
sunnycoder earned 350 total points
ID: 18051469
To run it with xinetd, enable the service in the xinetd configuration file (/etc/xinetd.d/vsftpd) and then restart xinetd
0
 

Author Comment

by:Bloodrule
ID: 18056437
In the end I used a mix of the answers (so I am splitting the points) and this worked, remembering this is Suse 10.0:

To stop: /etc/init.d/ killall xinetd
To start: /etc/init.d/ xinetd &
0

Featured Post

Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This is the error message I got (CODE) Error caused by incompatible libmp3lame 3.98-2 with ffmpeg I've googled this error message and found out sometimes it attaches this note "can be treated with downgrade libmp3lame to version 3.97 or 3.98" …
Join Greg Farro and Ethan Banks from Packet Pushers (http://packetpushers.net/podcast/podcasts/pq-show-93-smart-network-monitoring-paessler-sponsored/) and Greg Ross from Paessler (https://www.paessler.com/prtg) for a discussion about smart network …
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial
Suggested Courses

710 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question