Solved

Linux Fedora Core 4/5 upgrade failure, need help

Posted on 2006-11-30
7
220 Views
Last Modified: 2013-12-06
Hey,

I have a big problem. I had an active FC4 installation that was working.

I upgraded the system to FC5, and the system won't boot, saying unable to mount the partition.

I tried using FC5's rescue mode, my information are still in the HD, so I should be able to move them out and start fresh again.

However, there is no Samba, in Resue mode, is there?

The major question is, Is it possible to repair this situation?
Or is there a live CD that can tap into my system's hd and allow me to smb the information back on to other computers on my network?

(I have a Windows Network, that's why I need smb function).

0
Comment
Question by:SamsonChung
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 2
7 Comments
 
LVL 5

Expert Comment

by:dasmaer
ID: 18045801
Hi Samson

It sounds like somehow your /etc/fstab has become messed with. In rescue mode try doing:

fdisk -l

This should show you what partitions are configured at boot. Have a look at this article: http://fedoranews.org/blog/?p=676 It's aimed at getting a FAT32 or NTFS partition mounted, but there is no reason why you can;t apply the same method (with appropriate differing values) to get a ext3/2 fs mounted.

Have a shot and post back.

D
0
 
LVL 6

Author Comment

by:SamsonChung
ID: 18046001
Thanks,

I'll go and try this as soon as I can get access back to my system....

0
 
LVL 6

Author Comment

by:SamsonChung
ID: 18050976
Hey

I tried it, i got hda1 and hda2.

my system's hd is mounted. Is there a way to smb the files in rescue mode to my windows file spaces?
0
Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

 
LVL 5

Accepted Solution

by:
dasmaer earned 500 total points
ID: 18052625
You should be able to use mount to mount up your partitions using the tutorial I pointed to earlier... so then you could boot into normal mode as the partition's will mount.

If not, from the terminal in rescue mode, you should be able to type "kdm" to get KDE up and running (and hopefully with Samba running too).
0
 
LVL 6

Author Comment

by:SamsonChung
ID: 18054926
Nice...

I will try that tonight.

(I was using SSH to my other FC5.... lol it was annoying....)
0
 
LVL 6

Author Comment

by:SamsonChung
ID: 18069936
Hey,

the following is what I did.

load up using Rescue linux on the FC 5 DVD.

English, us keyboard
enabled DHCP on network

chroot /mnt/sysimage

kdm

system loads and no response. but the prompt continue to function.

I then tried it with the FC5 Rescue CD, same thing.

How did you get KDE to work?
0
 
LVL 6

Author Comment

by:SamsonChung
ID: 18076532
Thanks,

didn't solve my problem, but atleast I learnt that I shouldn't have upgraded it like that.

:)
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

In my business, I use the LTS (Long Term Support) versions of Linux. My workstations do real work, and so I rarely have the patience to deal with silly problems caused by an upgraded kernel that had experimental software on it to begin with from a r…
The purpose of this article is to demonstrate how we can upgrade Python from version 2.7.6 to Python 2.7.10 on the Linux Mint operating system. I am using an Oracle Virtual Box where I have installed Linux Mint operating system version 17.2. Once yo…
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

732 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question