Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

How do I manage "Public Folders" permissions from exchange?

Posted on 2006-11-30
10
Medium Priority
?
709 Views
Last Modified: 2013-12-03
In Exchange System Manager I get to our Public Folders by going to:
COMPANY (Exchange)
>Administrative Groups
>>First Administrative Group
>>>Servers
>>>>EXCHANGE01
>>>>>First Storage Group
>>>>>>Public Folder Store
>>>>>>>Public Folders

If I right click on any folders and go to properties, I get the following error:
"The token supplied to the function is invalid

ID no: 80090308
Exchange System Manager"

How can I manage permissions?  Some of the people who own public folders no longer work here, and our previous admin deleted their accounts.
0
Comment
Question by:OneSeventeen
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 5
10 Comments
 
LVL 35

Assisted Solution

by:rakeshmiglani
rakeshmiglani earned 2000 total points
ID: 18046173
don't go into the public folder store
there is an object called folders and when you expand that you get to see "all public folders" under that you willsee all folders. manage them from there.
also if this is e2k3 sp2 then it has some improvements over sp1
0
 
LVL 35

Accepted Solution

by:
rakeshmiglani earned 2000 total points
ID: 18046220
0
 
LVL 1

Author Comment

by:OneSeventeen
ID: 18046230
When I go to:
COMPANY(exchange) > Administrative Groups > First Administrative Groups > Folders > Public Folders

I am immediately greeted with:
"The token supplied to the function is invalid

ID no: 80090308
Exchange System Manager"

And there are no items in the display.  If I right-click and go to the properties, it shows me that this is in fact mounted in the area I looked before, so this is the proper place that it "should" be.
0
Get your Conversational Ransomware Defense e‑book

This e-book gives you an insight into the ransomware threat and reviews the fundamentals of top-notch ransomware preparedness and recovery. To help you protect yourself and your organization. The initial infection may be inevitable, so the best protection is to be fully prepared.

 
LVL 35

Expert Comment

by:rakeshmiglani
ID: 18046244
check for SSL settings in IIS for the public folder virtual directory
0
 
LVL 1

Author Comment

by:OneSeventeen
ID: 18046273
Okay, on the SSL Certificate issue, do I have to purchase an SSL, and if I change the SSL to have the FQDN as I see the server from inside the network, does that mean it will break for everyone looking at the server from outside the network?  (I access it using a 10.0.0.x IP, but if I'm off site I'd access it via a global IP, and because of security policies I cannot access it from the global IP or domain name from within the network.)

Our server is exchange01.companyname.local. on the inside, but mail.companywebsite.com. on the outside of the network.
0
 
LVL 35

Expert Comment

by:rakeshmiglani
ID: 18046289
check the SSL on the public folder object in IIS and if it is enabled then disable it for the public object only. once done stop and restart the default website and then check
0
 
LVL 1

Author Comment

by:OneSeventeen
ID: 18046334
How do I disable it for the public object only?

And if I disable it, can I re-enable it later?
0
 
LVL 1

Author Comment

by:OneSeventeen
ID: 18046384
Also, which is the public folder object in IIS?  I do see under "Default Web Site" an object called "Public".  Is that what I'm looking for?

Will this impact the security of viewing the contents of the exchange public folders using outlook web access?
0
 
LVL 35

Expert Comment

by:rakeshmiglani
ID: 18046396
right click on the public virtual directory and click on properties
Click on directory security tab
under secure communications click on edit
over here the "require secure channel (ssl)" and "require 128-bit encryption should not be checked.
0
 
LVL 1

Author Comment

by:OneSeventeen
ID: 18046500
Okay, combining what you said earlier and the Microsoft Help article you referenced it works!!!

Thank you so much!

I was very hesitant to simply disable a secure certificate without knowing it wouldn't impact the security of the web-based site.

As per the article you referenced, I simply un-checked the require secure channel on the "Exadmin" object, applied that change, closed and re-opened exchange system manager and now it works!

Thanks for pointing out the details.  Knowing more about what I was doing made me feel much better about disabling the certificate.
0

Featured Post

Get your Disaster Recovery as a Service basics

Disaster Recovery as a Service is one go-to solution that revolutionizes DR planning. Implementing DRaaS could be an efficient process, easily accessible to non-DR experts. Learn about monitoring, testing, executing failovers and failbacks to ensure a "healthy" DR environment.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

A couple of months ago we ran into an issue that necessitated re-creating our Edge Subscriptions. However, when we attempted to execute the command: New-EdgeSubscription -filename C:\NewEdgeSub_01.xml we received an error indicating that the LDAP se…
Know the reasons and solutions to move/import EDB to New Exchange Server. Also, find out how to recover an Exchange .edb file and to restore the file back.
how to add IIS SMTP to handle application/Scanner relays into office 365.
A short tutorial showing how to set up an email signature in Outlook on the Web (previously known as OWA). For free email signatures designs, visit https://www.mail-signatures.com/articles/signature-templates/?sts=6651 If you want to manage em…
Suggested Courses

610 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question