Solved

Vista Business IP Issues

Posted on 2006-11-30
7
512 Views
Last Modified: 2012-06-27
I just installed/upgraded a Dell with XP Pro SP2 to the release of Vista Business.  I am a Volume License Customer and Microsoft pre-released it to us a few days ago.  Here is the problem, which by the way I experienced on a differerent system with an earlier beta or release candidate.  I chalked it up to being a beta, and went back to XP.  Now I upgraded a system to Vista Busiess, and when I had the same proiblem I blew away the system and installed the full version of Vista only to have the same problem.

The problem is I can't get an IP address.  Vista comes out of the box with both IPv4 and IPv6 selected.  I run a Win2k3 server hosting IPv4 DHCP and it works fine for any other device in my lab.  The workstation says it has limited connectivity because it won't get an IP from DHCP.  I have deslected the IPv6 option and am using ver 4 only.  When I look at the server, the DHCP IP list shows constant BAD_ADDRESS in it, which are coming directly from the Vista PC.  Each one of those BAD_ADDRESS listed in DHCP have a unique identifier to diffrentiate it from the initial mac address.  I have even gone into the properties of my nic and changed its mac address, still no luck.  When I look at the logs of the workstation and server, it is complaining about a duplicate IP address and then DHCP tries to deliver another address and it just keeps going on and on.  I have Googled this problem to no avail, asked all my tech buds and no one has a clue.  If this is what we can expect out of a commercially released product in Vista, I'll still with XP or the gretest OS ever built Windows 2000.  I also have tried just statically assigning IP info and an IPCONFIG shows that no matter what address I assign to the NIC it shows up as a duplicate.  Racking my brains for a few days now and no luck, any help would be greatly appreciated.
0
Comment
Question by:tocmis
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
7 Comments
 
LVL 22

Accepted Solution

by:
Adam Leinss earned 250 total points
ID: 18047866
Using Vista Enterprise (final version) here with no DHCP problems.  Does it do it with all editions of Vista?  You can install any edition without a product key and have it work for 30 days.  I would start there.  Also, is it possible you have some bad media?
0
 
LVL 9

Expert Comment

by:NYtechGuy
ID: 18048420

I have seen this problem with windows XP SP2, and by right-clicking the connection and choosing "repair" it fixed it.  Sounds too simple almost.

I would also wonder whether, if you statically address the vista pc, does it get online ok?

thanks - Justin
0
 

Author Comment

by:tocmis
ID: 18048909
No as I mentioned even with me statically assigning a IP it still says it's a duplicate address.
0
Why Off-Site Backups Are The Only Way To Go

You are probably backing up your data—but how and where? Ransomware is on the rise and there are variants that specifically target backups. Read on to discover why off-site is the way to go.

 
LVL 9

Expert Comment

by:NYtechGuy
ID: 18049166
sorry, missed that.

Did you/could you try to swap out the nic, perhaps for a nic from a different manufacturer

/justin
0
 

Author Comment

by:tocmis
ID: 18049266
It's an embedded Intel Pro VE 10/100 on the systemboard of this Dell.  I am going to try a different nic tonight and see if that makes a difference.  The odd part is the nic shows up fine, has no errors or conflicts and Vista says it is functiong properly.  i get a error 1232 when I try to ping anything on my local subnet with a statically assigned IP, once again I can't get an address from DHCP.
0
 
LVL 20

Expert Comment

by:jimmymcp02
ID: 18049782
Disabled the onboard nic card and install new nic.

i saw issues like that on RC1 people keep saying that they could not acquire DHCP on vista RC1 apperently microsoft made some major fixes on RC2 for drivers perhaps yours just slip through the crack get a 3com card you should be OK
0
 

Author Comment

by:tocmis
ID: 18068852
I have figured it out.  It turns out there are some bugs in IE7, that only allow pages to be displayed in "another window or tab".  If you load up IE7 and the main MSN default page loads, your fine.  However if you click on any url on the page it times out.  Take that same link and right-click "open in new tab or window" and it opens fine.  Found a lot of hits on this issue all over the net.  Installed Mozilla Firefox and everything works great.  I knew something was up because even though I couldn't browse properly, I could ping everything outside and all my streaming applications worked fine, just not browsing.  Maybe MS will get their act straight before they release an OS like this. Probably not!
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Introduction How to create multiboot configuration with XP\Vista and Windows 7 on it? And most important question - how to do this correctly so not to have any kind of nightmares we get when system gets screwed? First of all one should realize t…
Windows 7 does not have the best desktop search built in. This is something Windows 7 users have struggled with. You type something in, and your search results don’t always match what you are looking for, or it doesn’t actually work at all. There ar…
This is used to tweak the memory usage for your computer, it is used for servers more so than workstations but just be careful editing registry settings as it may cause irreversible results. I hold no responsibility for anything you do to the regist…
Hi friends,  in this video  I'll show you how new windows 10 user can learn the using of windows 10. Thank you.

717 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question