Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 787
  • Last Modified:

How do I disable the Open, Save, Cancel prompt box in Internet Explorer when opening an EXE file wrapped in web page?

Hey All!

We currently have a streaming Media server that streams audio, video, flash files, and program executables on our Intranet. All of the file formats I've mentioned are wrapped in an HTML web page. The whole idea is to keep all files centralized on our Media server and wrap these files in HTML (3KB) so that these HTML files can be distributed amongst our Intranet without having the users to download these file types.

My issue is that when an HTML (wrapped around an EXE file ONLY) is opened in Internet Explorer a prompt box appears asking to either Open, Save, Cancel. Naturally I just want the the HTML to open the EXE file WITHOUT the IE prompt box appearing. I know that the reason Microsoft has this prompt box appear in IE is so that the user is aware of something being downloaded onto their machine.

However is there a way to let Internet Explorer open the application by default and not have the Open, Save, Cancel prompt box to appear?  
0
HCAAdmin
Asked:
HCAAdmin
1 Solution
 
war1Commented:
Greetings, HCAAdmin !

Go to Windows Explorer > Tools > Folder Options > File Types.
Scroll down to EXE and highlight it.
Select Advanced and uncheck "Confirm Open After Download" check box.
Click OK.

Best wishes!
0
 
psyki_beCommented:
Of course, you'll have to do this on every user machine.

And this is a very dangerous setting.
Every browser puts that option there for a reason.

It's very dangerous to let websites download and run applications without the users knowledge.
This is extremely dangerous for virusses, spyware,...
0
 
war1Commented:
HCAadmin,

We have not heard from you. Did any comment help you solve your problem? Do you have any more question? If an Expert helped you, please accept his/her answer above with an excellent or good grade.

Thanks, war1
0
Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
HCAAdminAuthor Commented:
We were unable to find the exe extension under file types under internet explorer. When we tried to add it we were told it already exists?
0
 
war1Commented:
HCAAdmin,

If the EXE extension is not available, then you cannot disable the warning.  It is there for security purpose.
0
 
war1Commented:
Thanks Verabili and Computer101
0
 
HDH-InformationSystemsCommented:
I actually just encountered this same problem with a vendor supported web based application we run. The application opens files that are stored locally to the workstation which connect to a database on a remote server.

Regardless of whether the application extension had the check in "confirm open after download" the pages would prompt you to open. This happened each and every step of the way while using this web browser based application. I tried putting different items in the trusted zones of IE. I also tried repeatedly enabling, disabling deleting, recreating the extension listing in explorer options.

Finally I deleted it, opened the shortcut and let windows recreate it for me. This worked. The browser based application no longer asks top "open, save, cancel."
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now