SSH running,can't login - sshd_config is commented out

I have a Linux box I need to remote into.  SSH is running and I can get a prompt remotely, but I can't login.

I tried seeing what is up with sshd_config, but the lines are completely commented out (I did a search and found two - both the same)

Marketing_InsistsAsked:
Who is Participating?
 
TintinConnect With a Mentor Commented:
What message do you get when trying to login?

Try running sshd in debug mode then try logging in again.
0
 
Marketing_InsistsAuthor Commented:
So if it's using a different config file, how can I find it?
0
 
talkster5Commented:
Are you trying to login as root? If so then direct root login may be disabled.

Do you have a console plugged into this Linux box which you are able to use or is the machine remote as well?
0
Cloud Class® Course: Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

 
Marketing_InsistsAuthor Commented:
I'm trying to log in as a regular user whose logon works from the physical box

I can get to it locally.  But the sshd_config files is commented out entirely.

I don't see how sshd can run if every line of it's config file is commented out, as I have no problem getting a remote prompt,  so I'm wondering if it's referring to a different config file and how I can find it?
0
 
talkster5Commented:
The configuration file should be /etc/ssh/sshd_config. Is this the file that is commented out?
0
 
TintinCommented:
If every field in /etc/ssh/sshd_config is commented out, then sshd will be using all the defaults.

What message do you get when trying to login?
0
 
Marketing_InsistsAuthor Commented:
on this Suse system:
/usr/local/etc/sshd_config

# every line
# is commented out

0
 
Marketing_InsistsAuthor Commented:
Sorry tin, I commented before I hit refresh and saw your message, let me see...
0
 
Marketing_InsistsAuthor Commented:
It's says "authentication disabled"
0
 
Marketing_InsistsAuthor Commented:
Ahh!  While I was at the terminal, I tried to ssh to 127.0.0.1,

I get the error. "Permission Denied (Public Key)"

I'm guessing it's a public key authentication thing.

How can I disable Public Key authentication so I can use a regular user-name and password?
0
 
joshmia2001Connect With a Mentor Commented:
 Post your ssh config file, what distro are you using?
  In the sshd_conf file you should see an option for passwords, make sure you can log in using passwords.  If you post your sshd_config I am sure someone here could pick it apart.

Joshua McDowell
0
 
DonConsolioConnect With a Mentor Commented:
try logging in with the "-v" option to get verbose output on the client side

if the result isn't giving you enough clues you can post it here for comments

you can also try to start the server with the "-d" option to get debugging output (probably to syslog)
(the ssh server needs to be restarted after each login attempt when "-d" is used)


0
 
Marketing_InsistsAuthor Commented:
OK, It will take me a day to get back to this. server-room construction :-/
0
 
Marketing_InsistsAuthor Commented:
I can't get back to this issue, it will have to wait for a while, but thank you for the suggestions!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.