• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 763
  • Last Modified:

Cannot map share on Win 2003 server

Okay, I'm officially desperate. I recently set up a Windows 2003 server on new hardware. This was to replace our old server. Installed everything from scratch (except web). Created a shared folder like one we had on the old server. All the permissions, etc., appear to be the same. Old server is off-line now; new server has old server's name and IP address.

I can't for the life of me map the shared folder on my Windows XP computer - on any computer I've tried, for that matter. Actually, I can't map any share. I get the following error: "Network path \\newserver\sharex could not be found." I've tried with the IP address of "newserver" as well as the complete name. "Newserver" is a simple stand-alone server: no active directory, no domain, no DNS server, no DHCP server.

I can ping "newserver" with both the name and the IP address. I can even setup a Remote Desktop connection to "newserver" from my PC. I just can't access any dang shares. I know this is probably something simple I've overlooked, but I'm admitting defeat and calling in the big guns.

Thanks in advance for your help!

Gaz
0
Gazaway
Asked:
Gazaway
  • 5
  • 3
  • 2
1 Solution
 
Scott AndersonPrincipal Support EngineerCommented:
Since you mentioned "something simple I overlooked", I'm obliged to ask: Windows Firewall?

Aside from that, what about permissions on the Network Share and the Shared folder.  
Also, for funsies, at a command prompt, type:   net shares   to make sure the share that is setup is actually being shared out...
Also, also, can you "browse" to the share through Network Neighborhood?
0
 
GazawayAuthor Commented:
Scooter,

net shares: Yes, it's there and defined correctly.

Share Permissions: Administrators - Full; Everyone - Read

Folder Permissions: Administrators, Everyone - Full

Network Neighborhood: No, I can't see it, but it is on a different subnet. Actually, the server has a public address and user workstations are NATed. However, this has been the setup for a couple of years and never got in the way of accessing shares on the old server.

Firewall - Yes. I have "File and Printer Sharing" checked. However, I tried taking the firewall down this morning and was able to connect. So this appears to be the culprit. Is there a port I need to have open in addition to enabling file sharing? I'm not enthused about running a public server without the firewall in place!

Gaz
0
 
rizla7Commented:
He meant, disable the firewall on your XP client, how is that the server?  and you don't need a pirated copy of win2k3 to run a public web server. all you need is win xp pro or 5$/month for a web hosting solution.
0
Cloud Class® Course: Amazon Web Services - Basic

Are you thinking about creating an Amazon Web Services account for your business? Not sure where to start? In this course you’ll get an overview of the history of AWS and take a tour of their user interface.

 
GazawayAuthor Commented:
rizla7,

I don't understand your comments. The firewall on the client is not the problem as I can access shares on other computers from my XP computer and I've tried multiple XP clients that can't access the server.

The Windows 2003 Server I'm running is NOT pirated! It is completely legit. I don't believe in running pirated software or operating systems! I'm not sure where you got the idea that it was pirated.

The server performs several other functions besides web serving.

Anyway, none of this serves to solve the problem I've presented.
0
 
GazawayAuthor Commented:
I foiund the answer myself. The scope on "file and printer sharing" in the firewall was set to "subnet" for all ports. Once this was opened up, I was able to map the drives successfully.
0
 
rizla7Commented:
you should award the points to scooter imo, since he pointed out the firewalls first, even though it was my comment that prompted you to take a closer look at those firewall policies.  you didn't state that information in your original question or any comments.
0
 
GazawayAuthor Commented:
Sorry, rizla7, I disagree. I found the answer by working with folks in another venue. Scooter never followed up after I replied to his post, and he never suggested that I try disabling the firewall. As for your post, don't make me laugh! The only thing it prompted me to do was recognize how insulting and off-topic it was.
0
 
Scott AndersonPrincipal Support EngineerCommented:
Hmmm...  Sorry I didn't reply - been out of the office then (as always) had to pay the price for being out of the office (a ton of stuff stacked up while I was out).

Just reviewing the notes, disabling the firewall on the server discovered the "smoking gun", it appears.  Often times, it's just a matter of putting together what you do know - kinda like the Sherlock Holmes maxim:  "First rule out the impossible, what remains is, indeed, possible..."

Glad that you got it figured out.

Scooter
0
 
GazawayAuthor Commented:
I won't quibble about the points, but the answer really came from a couple of folks with no association with EE so I can't in good conscience give a high grade.
0
 
Scott AndersonPrincipal Support EngineerCommented:
Sorry, didn't mean to be lobbying there...  regardless, glad it got figured out...

Scooter
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

  • 5
  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now