Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 250
  • Last Modified:

DNS resolution is with a public domain

Here is the deal.

I have two seperate forests with a two way trust between them.  Unfortunately when the created one of the forests they named it, forest.net.  So when a user from forest A tries to go to Forest B, which is named forest.net, they are getting routed out to the internet because the .net root.  Amazingly enough someone out there has actually bought this domain.

How do i permanently set forest.net requests to be sent to the forest.net domain DNS servers all the time?
0
YankeeFan03
Asked:
YankeeFan03
1 Solution
 
cmihelichCommented:
Depends on how the internal clients are resolving the DNS request.  If they're pointed only to the server the request should be picked up and resolved to the internal domain.  If they're pointed to to an external DNS source they'll pickup forest.net as an external server.

Set the clients to resolve DNS to the internal DNS servers.  Enable DNS forwarding on the DNS servers to resolve outside requests by forwarding to an external DNS server.

From the DNS management snapin right click on the server and select properties.  Under forwarders there is an entry for 'All other DNS domains'.  Add external DNS servers to this to resolve outside domains for your clients that request it.

0
 
Hypercat (Deb)Commented:
You can set up a forwarder for a specific domain in the DNS settings.  On the forwarders tab, at the top there is a box labeled "DNS Domain."  If you already have forwarders set up, there's an entry in there for "All other...."  Click New to add an entry for forest.net.  Then specify the DNS server that you want to use to serve inquiries for that domain.  Of course, you realize that this will mean that your users won't be able to get to the public "forest.net" domain, but that probably doesn't matter to you :-)

Hope this helps!
0
 
YankeeFan03Author Commented:
thanks hypecat, exactly what i needed.  i will try it tomorrow.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now