Solved

Weird problems with an XP PC.

Posted on 2006-11-30
5
479 Views
Last Modified: 2012-05-05
I just had a weird experience with an XP domain member PC. The machine is a win2k workstation that had been upgraded to XP several months ago. It doesn't have many applications installed on it as it is used primarily as a proxy (WEB) on which an application named "WEBMarshal" is running. WEBMarshal receives requests from within our domain for web pages and determines through policies and member lists whether that request should be honored and that page displayed to the requestor . The problems started yesterday with pages not being displayed as requested. I looked at the PC and couldn't get any pages on the actual proxy PC itself I tried pinging other machines ao our network and was able to ping every one I tried. I tried pinging the proxy from the other workstations and was able to do that also. I made sure that all of the setting for the application and it's proxy configuration were correct, and they were.I made certain that our DNS & DHCP records all looked correct and they did.

The other weird thing going on was after a reboot, I got this message, "Your system has no paging file, or the paging file is too small. To fix this problem, go to system in the control panel, click the advanced tab, settings and advanced. Click custom size and set the pagefile to at least.............."  I did all that and the pagefile had been set to something like 245 MB and the PC has created a temporary pagefile of 265 MB to get around the issue. I clicked Custom and set it to a minimum of 1500 MB with a maximum of 2300 MB and clicked set. After clicking it, it remained at a size of 265 MB and said it needed a reboot. I rebooted and got the error again and reset the size again and rebooted again, several more times and it never changed.

I then got the bright idea to use system restore to fix whatever the problem was, so I started System restore and figured that if I returned the system to the 1st of November, that we'd be OK. I did and it went through the process and rebooted, after rebooting it said that it wasn't able to restore the sytem to that date. I tried another date with the same results and again it failed.


Looking in the event viewer I noticed the following Information Event, " NMS initialization during system startup failed" and couldn't remember having seen that one before. With no Internet I wasn't able to Google it so I decided to look through the services.msc and found several services disabled, they are/were. "Intel NMS", "Network DDE" and "Network DDE DSDM". I was able to start the Intel NMS and the Network DDE after reading the descriptions it sounded as if they were necessary for network connectivity so i changed their states from "disabled" to "Automatic" and started each one. Now, however the Network DDE is back to "disabled" somehow. Anyways, as soon as I started those, I was able to get a web page and shortly after that everyone else was able to as well. So now everybody is happy because they can get on the web and check out the scores on ESPN, or whatever, but I'm wondering what the heck happened to cause all of that. The machine in question is in a locked office (mine) and is never even looked at unless something goes wrong with the web access so I know that no one tampered with it.

Anyone have any ideas on why those services were disabled (they sound like they are necessary services) and are disabled again. And why everything worked after I started them? Or why I couldn't use sytem restore, or what happened with the pagefile?
0
Comment
Question by:dwielgosz
  • 2
5 Comments
 
LVL 24

Expert Comment

by:Kenneniah
ID: 18049618
Have you run comprehensive anit-virus and spyware scans on this system?
Is this computer directly connected to the internet, and if so are you running intrusion detection sofware and a good firewall?
Just because the computer is in a locked room does not mean it's secure. You can just about anything remotely to an xp machine as you can locally if your user account has access. So take a look at security on that machine, make sure no unecessary users/groups are in the Administrators group or even the Power Users etc.
Is this on a Domain or a local Workgroup?

As to why it wasn't working....I don't know anything about WEBMarshall, but if I had to guess I would assume it's using DDE to manage internet access. On most computers Network DDE can be disabled with no problems, but if WEBMarshall is using DDE, that would explain why this one didn't.

Now does Network DDE get disabled on every reboot?
0
 

Author Comment

by:dwielgosz
ID: 18053921
Thanks for the comment. The PC is in a domain and connects too the internet through a pix. The PC is also a client of Trend Micro's messaging for SMB server on our network(I think tha's the name). Whether the TrendMicro product is protecting it, I can not answer although I do have the firewall feature enabled on that software as well as the pix firewall. All of our email is scanned off-site by SOPHOS (proxied to and from). I must check the admin group though because that's a good suggestion.  The MB is an Intel D845PESV and may not have some current software running that was part of the board CD when we purchased it as this board is in it's second or third run in a system.
0
 

Author Comment

by:dwielgosz
ID: 18166065
For followup: I noticed that the hard drive on this machine was a little low on space, less than a gigabyte out of 40 gigs so I replaced the harddrive with one of those inexpensive monster drives (200 gig). After I got the machine back up and running with the new drive, all of the "problems" that had been occurring suddenly went away. So, I would have to assume that the drive running out of space was the cause. That would explain why I couldn't resize the page file and probably also why system restore wouldn't work. I would imagine that system restore uses ard drive space to move data around during that process. Thanks for the answers and I hope this helps someone else with a similiar problem.
0
 

Accepted Solution

by:
PashaMod earned 0 total points
ID: 18198427
Closed, 500 points refunded.
PashaMod
Community Support Moderator
0

Featured Post

Find Ransomware Secrets With All-Source Analysis

Ransomware has become a major concern for organizations; its prevalence has grown due to past successes achieved by threat actors. While each ransomware variant is different, we’ve seen some common tactics and trends used among the authors of the malware.

Join & Write a Comment

Suggested Solutions

Ok I have been working on this for some time having learned and gained certification in XenDesktop 4 along came version 5 which was released last month. Since then I have been working to deploy XenDesktop 5 in a small environment with only 2 virt…
Issue: Unstable cursor in Windows XP and Windows runs extremely slow in that any click will bring up the Hour glass (sometimes for several seconds before giving you what you want) . Troubleshooting Process and the FINAL FIX: This issue see…
Excel styles will make formatting consistent and let you apply and change formatting faster. In this tutorial, you'll learn how to use Excel's built-in styles, how to modify styles, and how to create your own. You'll also learn how to use your custo…
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…

757 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

23 Experts available now in Live!

Get 1:1 Help Now