Desktop redirection

I havw set up a Group Policy that is working. I want to redirect all desktops to the same location. I have made a folder and called it Desktop and shared it on the server. I have redireceted the Folder Redirecton Desktop in the GPO to \\ServerName\Desktop$, but it doesn't work. Do I need the $, and if so why, and why doesn't it work on the client machines?
Who is Participating?
Phadke_hemantConnect With a Mentor Commented:
open group policy editor - user configuration - windows settings - folder redirection - configure desktop properties to Basic -Redirect everyones folder to same location and give the root path for the shared folder (without $)
please make sure that the shared folder has sufficient rights on share as well as NTFS permissions so that people can access it and write (add) data to the respected folder
Irwin SantosComputer Integration SpecialistCommented:
use an explicit folder name without the "$"
The "String" Sign ($) is normally used to designate the "Admin" share on a HDD partition.

When you look at that share using Windows Explorer, does the share icon have a small hand holding it from the bottom?
The default setting on shares is to enable 'By-pass Traverse Checking', so unless you've modified that, your users should have access.

Good Luck,
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

jontyplattAuthor Commented:
I have set the folder with sufficient rights - where do I set the NTFS permissions?

in the GPO you have set to redirect everyones desktop, you will need to put in the path using the share name of the folder.

The $ sign will hide the share, not the folder, just the share, so say for example that someone browses to \\servername they would by default see your share called desktop unless in the share as name you called it desktop$ - this is not the actual folder that you name desktop$ just the share name.

once you have setup the share, you will need to give everyone full control to the share and then restrict it via ntfs permissions - if you want users to read and wrtie to the desktop, give them full / modify permissions - you can get to this screen by right clicking on the folder, and selecting the security tab, you can then use the relevent group, ie Authenticated Users, or Domain Users, or everyone - which ever suits your needs with the relevent permissions.

You will then need to either wait for replication to take effect, or force the gpo using the gpupdate/force command.

With regards to the gpo, you should configure it through the folder redirection policy under user settings. Select the desktop redirection, and set it to basic - redirect everyones folder to the same location, then in the target folder location select redirect to the following location and set the path to use \\servername\desktopsharename where desktopsharename is the name you specified when you shared the folder.

hope this clears it up for you...
you're using the "$" incorrectly.

In group policy you need to redirect like so


When you use the variable %username% it automatically assumes the user's username.  

Of course the server name you used above must have a folder created for that user.  Example:  For John Doe called jdoe for example.

where do I set the NTFS permissions?
=> folder/ drive properties - security tab
This falls in the category of 'none of my business', but DenisCooper explicitly answered some of your questions and you left him completely out when you awarded points.

In case you don't realize it, you can 'split points' when 2 or more users help you with a solution.

My $.02 worth.

jontyplattAuthor Commented:
Thanks for your comments and I accept what you say. Unfortunatley I work in a very busy environment and am regularly under pressure - from now to the end of January is one of them! I am concious to award points and must admit to doing this on an ad hoc basis - I will try to be fairer in future. On this case I just looked down and saw who answered first, but your criticisn is valid
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.