• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2522
  • Last Modified:

IIS restart giving Event ID 7031

Hi, I got exchange 2003 with service pack 1 on windows 2000 (service pack 4)(member Server). The domain controller is on a diffrent server (win 2000 service pack 4). From yeasterday i got the following problem my IIS service restarts it self giving the following errors

Event Type: Error
Event Source: Service Control Manager
Event Category: None
Event ID: 7031
User: N/A
Computer: XXXXXXXX
Description:
The IIS Admin Service service terminated unexpectedly. It has done this X time(s). The following corrective action will be taken in 1 milliseconds: Run the configured recovery program.

Event Type: Error
Event Source: Service Control Manager
Event Category: None
Event ID: 7031
User: N/A
Computer: XXXXXXXX
Description:
The Microsoft Exchange IMAP4 service terminated unexpectedly. It has done this X time(s). The following corrective action will be taken in 0 milliseconds: No action.

Event Type: Error
Event Source: Service Control Manager
Event Category: None
Event ID: 7031
User: N/A
Computer: XXXXXXXX
Description:
The FTP Publishing Service service terminated unexpectedly. It has done this 6 time(s). The following corrective action will be taken in 0 milliseconds: No action.

Event Type: Error
Event Source: Service Control Manager
Event Category: None
Event ID: 7031
User: N/A
Computer: XXXXXXXX
Description:
The Network News Transport Protocol (NNTP) service terminated unexpectedly. It has done this 6 time(s). The following corrective action will be taken in 0 milliseconds: No action.

Event Type: Error
Event Source: Service Control Manager
Event Category: None
Event ID: 7031
User: N/A
Computer: XXXXXXXX
Description:
The Microsoft Exchange POP3 service terminated unexpectedly. It has done this 6 time(s). The following corrective action will be taken in 0 milliseconds: No action.

Event Type: Error
Event Source: Service Control Manager
Event Category: None
User: N/A
Computer: XXXXXXXX
Description:
The Microsoft Exchange Routing Engine service terminated unexpectedly. It has done this 6 time(s). The following corrective action will be taken in 0 milliseconds: No action.

Event Type: Error
Event Source: Service Control Manager
Event Category: None
Event ID: 7031
User: N/A
Computer: XXXXXXXX
Description:
The Simple Mail Transport Protocol (SMTP) service terminated unexpectedly. It has done this 6 time(s). The following corrective action will be taken in 0 milliseconds: No action.

Event Type: Error
Event Source: Service Control Manager
Event Category: None
Event ID: 7031
User: N/A
Computer: XXXXXXXX
Description:
The World Wide Web Publishing Service service terminated unexpectedly. It has done this 6 time(s). The following corrective action will be taken in 0 milliseconds: No action.

Event Type: Information
Event Source: IISCTLS
Event Category: None
Event ID: 2

User: N/A
Computer: XXXXXXXX
Description:
IIS stop command received from user NT AUTHORITY\SYSTEM. The logged data is the status code.
For additional information specific to this message please visit the Microsoft Online Support site located at: http://www.microsoft.com/contentredirect.asp.

Event Type: Information
Event Source: IISCTLS
Event Category: None
Event ID: 1
User: N/A
Computer: XXXXXXXX
Description:
IIS start command received from user NT AUTHORITY\SYSTEM. The logged data is the status code.
For additional information specific to this message please visit the Microsoft Online Support site located at: http://www.microsoft.com/contentredirect.asp.


I have tried the following link http://support.microsoft.com/kb/885264/#appliesto

and downloaded the patch but when i run the patch it gives me following error


Setup has detected that the Service pack version of the system installed is newer then the update you are applying to i. You can install these update on RTM only.

I also have Symentac client secutiry 3.0 and mail security 5.0 but could not find any thing. Please help
Regards,
0
upl
Asked:
upl
  • 5
  • 4
  • 2
  • +1
1 Solution
 
SembeeCommented:
IIS ADMIN crashes and pulls the rest of the services down.

Any reason you are not on Exchange 2003 SP2? I would suggest installing that first and see if the problem goes away.

Simon.
0
 
uplAuthor Commented:
Is this suggestion or solution?

Javed.
0
 
MATTHEW_LCommented:
I would also agree with Sembee.  SP2 for Exchange has been out for a while and has quite a few rollups in it.  This really should be installed on Production mail servers.  Even if it does not fix the problem that you are having SP2 is something you should install.
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
mmudryCommented:
Take a look at the following patch.  It may however already be included is SP3 or SP4.

http://support.microsoft.com/default.aspx?scid=kb;en-us;311517
0
 
uplAuthor Commented:
ok i tried service pack 2 for exchange 2003 actually as i was using mail security 5.0 so i did not wanted the service pack 2. It worked intially fine for 2 hours but again the services have restarted giving the same errors. I have also completely checked event log for past three days, there is no other error then these. Hope some thing comes up.
0
 
uplAuthor Commented:
"mmudry "

i have the latest service packs (4 for window 2000) with rollup 1 and i have tried every book method :) and its not working out it has done this 26 times now
0
 
MATTHEW_LCommented:
This could be used as a last ditch effort.  Keep your options open for now though.  You can reinstall IIS on your Exchange Server.  This is a big process and should not be taken lightly.  It also requires a reinstall of Exhcnage and copying make Exchange Data.
http://support.microsoft.com/default.aspx?scid=kb;en-us;320202

Have you turned up the debug Logging on Exchange?  Also, checked for viruses etc?
0
 
MATTHEW_LCommented:
Also if you are running any AV software etc, try shutting those down for a moment by stopping the services, restart exchange services and see if there is any change in the service state.
0
 
uplAuthor Commented:
"Matthew L "


I intially thought on the same lines that this might be work of Blaster or LoveSan but Symantec (Client Security 3.0) is most updated and i tried scaning and nothing trunned up.
0
 
MATTHEW_LCommented:
Can you try disabling your mail security product and or av for a period of time, restart exchange services and see if the services continue to restart?
0
 
uplAuthor Commented:
ok let me give it a try i will bounce back
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

  • 5
  • 4
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now