Solved

SATA drive recognition by motherboard and bios

Posted on 2006-12-01
16
427 Views
Last Modified: 2010-04-25
Scenario:
OS = XP Pro SP2 w/all patches/updates as of 1 Dec 06
Mobo: GA - 8IPE 1000G [purchased in 2005]
Hard Drives: Channel 0 Master IDE = WDC 20GB; Channel 0 slave = 20GB Maxtor
Channel 1 Primary = WDC SATA 250GB, Channel 1 slave = Sony DVD-R/RW
Software: Symantec AV vewr 10.0.2.x
No other software installewds at this point

All mobo IDE, SATA, power source cable connections verified connected

Problem:
I connect Primary IDE [OS disk] hard drive and can verify BIOS recognition and system starts fine.
However, when I connect the CHannel 0 slave drive BIOS recognizes it, but OS disk mgmt cannot see it, not even after disk re-scan performed or in My Computer and no errors show in Dev mngr.

So, I disconnect CHannel 0 slave drive and connect Channel 1 SATA drive - it is recognized by BIOS, but system hangs after post boot test and IDE drive recognition - boot process stops [no errors].
I then, disconnect SATA drive, verify connections, power - all is good, but same result on bot up.

Q:
1. There are jumpewr positiona avail on SATA drive, but I do not recognize the position choices - they are not listed as "Master; SL; CS", like an IDE drive --where do I place a jumper if I want the SATA disk to function as Channel 1 Master, with the DVD-R drive as Channel 1 slave [it has the IDE - to- SATA adapter kit on it and is plugged into SATA Slave position on mobo.

2. Why can't I get hte system to recognize the disk drives and get the IDE and SATA to work thru boot up and into usable disks? What am I missing?

Stuck on stupid here...thanks :)



0
Comment
Question by:knowital
  • 9
  • 7
16 Comments
 

Author Comment

by:knowital
Comment Utility
Made a mis-entry above.

My mobo has 2 IDE inputs and 2 SATA inputs.

The Primary IDE [OS disk] is connected to the IDE1 input with another IDE HDD connected as a slave via second cable connection
The Primary SATA disk is connected to SATA1 and the DVD-R disk is connected to SATA2.
0
 
LVL 91

Accepted Solution

by:
nobus earned 500 total points
Comment Utility
1- where do I place a jumper if I want the SATA disk to function as Channel 1 Master  <<  there are no M/S jumpers on sata drive, only jumper to select transfer speed. Each Sata drive is Master on it's own channel, since you can only connect 1 drive
2- 2. Why can't I get hte system to recognize the disk drives   <<  more difficult to say. possibilities are :
- did you install the sata driver for your MOBO ?
- check if you have enough power :  http://extreme.outervision.com/psucalculator.jsp      
0
 

Author Comment

by:knowital
Comment Utility
Nobus: thanks for your reply.

Let me try your soltion suggestions tomorrow. I am overseas, so depending on hwere you are stateside, I am at least 6 hours ahead of your local time.

Will try these tomorrow after work and reply.

Remember also, at instances [i.e. if I connect IDE nad Slave IDE on Channel 0] thaen I CAN see the SATA Channel 1 Master drive, but no second SATA drive.

I DO haVE A JUMPER ON THE sata DRIVE. Should I just remove the jumper on teh Prinary SATA drive [and possibly the system works fine afterwards....]?
0
 
LVL 91

Expert Comment

by:nobus
Comment Utility
0
 

Author Comment

by:knowital
Comment Utility
ok. now I can't get the pc to boot. I disconnected everything except IDE Master [which I loaded XP SP2 on and applied all updates to, just last week]. So, re-installing XP on this drive again - it got stuck in the Boot up options windows and just kept looping back to that screen adn none of the boot up options worked.

Will have to start this over after install and updates are applied.

I have to go out of town until next Friday on business. I hope this question remains open til I returnm - my issue remains unresolved.
0
 
LVL 91

Expert Comment

by:nobus
Comment Utility
check the boot priority in the bios; if you want to boot from that disk, it must be set to it
0
 

Author Comment

by:knowital
Comment Utility
I did - I set CHannel Master to Sata_1 and CHannel 1 Slave to SATA_2 [the DVD-ROM].
CHannel 0 Master is hte primary IDE [OS] disk, which I did a full install of XP ProSP2 on and applied all the updates last week on--it just got swallowed, I guess!

Anyhow, I re-loaded the OS this morning, now, am jsut downloading/installing updates.

The BIOS for this mobo is at "F5" version. THere is an F6 version which I have downloaded, but of course, BIOS recognizes the DVD drive, but WINDOWS cannot see the OEM Drivers disk that accompanied the mobo - maybe some kind of UDF file reader must be installed first.

Still working this. I'll be able to tackle it thruSaturday night, CETime.

THanks for the replies and additional brain cells here ;)
0
 
LVL 91

Expert Comment

by:nobus
Comment Utility
>>  CHannel 1 Slave to SATA_2 [the DVD-ROM].   <<   what do you mean? the DVD is sata ?
0
IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 

Author Comment

by:knowital
Comment Utility
The DVD drive is a Sony DRU 710A [that, by the way doesn't read CD's, but does read DVD's and Sony [as of yesterday, still has not fix for this issue]. OEM, it is IDE ready, but I bought a IDE-to-SATA converter adapter and have tried plugging it on to the back of the DVD ROM nad then plugging a SATA cable into the adapter - so far, unsuccessfull at getting it recognized correctly by BIOS. So, meantime, while I load software, etc, I am just using the DVD ROM with an IDE cable [without the SATA adapter. I'd like it to be used in the SATA_2 slot though.
0
 
LVL 91

Expert Comment

by:nobus
Comment Utility
that is not a  good way to do things.
first, ensure the drive is working properly ( on another pc) if it is faulty, no "connection" will fix it.
adding an inbetween connection (ide-sata) just adds to the problem.
so: connect it directly to the ide (if it is proven ok) - it should be fine
0
 

Author Comment

by:knowital
Comment Utility
good point - normally I would not connect it that way - but always trying new things to see if they will work [and that still should work, tho not optimum]. Yes, the DVD drive does work - I loaded the OS with it and BIOS recognizes it, along w/Windows, until you pop a CD-R /RW in it - that is what Sony still cannot figure out. They told me yesterday the drive has a known laser issue when reading CD-R's and that they do not have a fix for it. How's that for customer service. :)

Anyway, I am trying to see how to get it to read CD-R's because it did once before [after pain-staking months of trying things, I did have it working [reading CD-R's] on another computer before].
0
 
LVL 91

Expert Comment

by:nobus
Comment Utility
>>  that, by the way doesn't read CD's  <<  if it does not read cd's - it is bad. you can verify it by trying to boot from a bootable cd (test it on another one to be sure)
>>  They told me yesterday the drive has a known laser issue when reading CD-R's and that they do not have a fix for it. How's that for customer service.   <<   lasers are not replaced; you just buy a new drive, or have  awarranty replacement
i would stopo playing with it, buy a new drive (they are cheap) and get on
0
 

Author Comment

by:knowital
Comment Utility
Thanks, I got it to work before and it will work again [there is a fix, I just can't remember how I got it to read CD-R's, like it should].

I'd like to focus on the SATA issue vs the DVD-ROM.

I have as Primary OS drive, an IDE drive and I also have two SATA drives I want to use on this pc, but I cannot get the mobo to SEE the drives even though BIOS recognizes the devices are connected. The mobo has two SATA slots listed as 'SATA 0' and 'SATA 1'.

Is there a conflict trying to use IDE drives and SATA drives on the same mobo?

Thanks.
0
 
LVL 91

Expert Comment

by:nobus
Comment Utility
you may have to check the boot options, and/or change them (boot from sata, other etc) or in the boot priority.
btw  : "Thanks, I got it to work before and it will work again [there is a fix, I just can't remember how I got it to read CD-R's, like it should]. "   if you find it, post it here - i'm curious as to how you fix it
0
 

Author Comment

by:knowital
Comment Utility
Thanks nobus. I will post it here when I track it down--I have eh solution on a drive somewhere here, but I just moved, so I have to re-assemble all my pc's drives; tehn I'll track and post it.

BTW: the laser works fine - there is a fix out there. Sony techs jsut don't know how to fix the issue. It has nothing to do with the laser...I'll get it working.

Still working this issue, so let me get back to it so I can post a final answer and points.

THanks again.
0
 

Author Comment

by:knowital
Comment Utility
If I keep this open until I get the fix, will EE admins close this question? It may take a couple of weeks yet.
0

Featured Post

What Security Threats Are You Missing?

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

Windows 7 does not have the best desktop search built in. This is something Windows 7 users have struggled with. You type something in, and your search results don’t always match what you are looking for, or it doesn’t actually work at all. There ar…
No matter the version of Windows you are using, you may have some problems with Windows Search running too slow or possibly not running at all. Before jumping into how you can solve this issue, just know there are many other viable alternative deskt…
It is a freely distributed piece of software for such tasks as photo retouching, image composition and image authoring. It works on many operating systems, in many languages.
This video shows how to remove a single email address from the Outlook 2010 Auto Suggestion memory. NOTE: For Outlook 2016 and 2013 perform the exact same steps. Open a new email: Click the New email button in Outlook. Start typing the address: …

728 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now