Solved

crystal reports - error: 2147206429 Invalid TLV Record

Posted on 2006-12-01
4
3,427 Views
Last Modified: 2011-10-03
i was unable to find a crystal reports section so i am posting this here, since i don't necessarily think this problem is specific to crystal reports.

we have an application that runs on a citrix server and is used throughout the country.  it has been in production for over a year without any problems.  after a recent build was applied suddenly all non-admin users receive this error: 2147206429 Invalid TLV Record, whenever a crystal report is opened in the app.

the app is running on a win2k sp4 citrix server.

i have tried to roll back the build, but that didn't change anything.

i talked to our IT department and they claim no updates were applied to the system.

i installed the app on a virtual machine with a base install ( winXP +updates only ) and found the error not present

i added sscsdk80.dll to the system32 folder

i verified the dependencies of craxdrt.dll

i regsvr32 numerous dlls

i scoured the web looking for solutions, but only came up with the above and others that did not work


i am at a loss as to why this is happening.  it is only happening on this server (test environment), but i am hesitant to apply any of the builds to production for fear of it happening there as well.  currently, the only solution i have been able to find, is to add all the app users into the admin group on the server, which, obviously i would rather not do.  any assistance is appreciated
0
Comment
Question by:meyerc74
4 Comments
 
LVL 10

Accepted Solution

by:
fostejo earned 500 total points
ID: 18056563
meyerc74,

You mention that the problem appeared "after a recent build was applied" so efforts should be concentrated on determining exactly what changes that recent build made. It's likely that the build installed updated Crystal Reports or other components which are not compatiable with some existing reports on the system.

Unfortunately, even though you've "rolled back the build", due to the way in which updates work, it's highly likely that some updated components still remained on the system afterwards, in particular any shared system DLLs which were upgraded, potentially leading to a mix of different DLL versions

You don't mention your exact version of CR, but the following link discusses a similar problem and lists a selection of CrystalDecisions support links which may help.

Also, another potential line of investigation would be to determine why the software fails with non-admin users only - is it trying to read/write a specific file or registry entry it no longer has access to?  Tools such as 'RegMon' and 'FileMon' can help - they're available from http://www.microsoft.com/technet/sysinternals/utilitiesindex.mspx

Hope that helps..


0
 
LVL 1

Expert Comment

by:rgss
ID: 18058117
I have had this issue after upgrading Crystal runtimes in the app to Crystal V9 (also in the Citrix environment). The invalid TLV message occurs when running a report that was written in Crystal V8. If you open the report files in Crystal V9 it will upgrade them for you, then resave them. Crystal V9 stores database names as part of table names in the query, but Crystal V8 doesnt. You may therefore also have issues when you implement the reports if they were developed and tested on a database with one name and then deployed to a database with another name.
0
 
LVL 100

Expert Comment

by:mlmcc
ID: 18063975
Crystal Reports forum
http://www.experts-exchange.com/Databases/Crystal_Reports/

What version of Crystal?

What did the build change?

mlmcc
0
 
LVL 1

Author Comment

by:meyerc74
ID: 18070822
thanks fostejo.  using filemon i found the permissions for atl.dll were set to admin and system only.
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
sumHeights  challenge 17 60
VMWare Workstation 12.0 3 86
allStar challenge 1 41
recursion example 16 68
Does the idea of dealing with bits scare or confuse you? Does it seem like a waste of time in an age where we all have terabytes of storage? If so, you're missing out on one of the core tools in every professional programmer's toolbox. Learn how to …
Since upgrading to Office 2013 or higher installing the Smart Indenter addin will fail. This article will explain how to install it so it will work regardless of the Office version installed.
Viewers will learn how to properly install Eclipse with the necessary JDK, and will take a look at an introductory Java program. Download Eclipse installation zip file: Extract files from zip file: Download and install JDK 8: Open Eclipse and …
In this fourth video of the Xpdf series, we discuss and demonstrate the PDFinfo utility, which retrieves the contents of a PDF's Info Dictionary, as well as some other information, including the page count. We show how to isolate the page count in a…

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now