?
Solved

Cannot browse internet when VPN is active

Posted on 2006-12-01
10
Medium Priority
?
1,016 Views
Last Modified: 2010-08-05
Remote users (Windows XP) cannot run VPN session and browse the internet simultaneously. When VPN connection is activated IE doesnot browse. Once VPN is disconnected browsing is possible.
0
Comment
Question by:nhftech
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
  • 2
  • +4
10 Comments
 
LVL 9

Expert Comment

by:JamesTX10
ID: 18054512
go to the properties of your VPN connection
networking tab
properties of TCP/IP
advanced
Check box use default gateway
0
 
LVL 13

Expert Comment

by:mrroonie
ID: 18054591
you mean UN-check the default gateway!
0
 
LVL 9

Expert Comment

by:JamesTX10
ID: 18054730
> you mean UN-check the default gateway!

Right. By default it is checked. By checking it again it will then be unchecked. Sorry I did not make that more clear.

JamesTX10
0
WordPress Tutorial 4: Recommended Plugins

Now that you have WordPress installed, understand the interface, and know how to install new parts, let’s take a look at our recommended plugins.

 
LVL 5

Accepted Solution

by:
WGhen earned 375 total points
ID: 18054734
Hi,
Many VPN clients have an option to allow local lan access.  By default, it may be set to not allow local access.
Some companies will pre-configure their clients to disallow local lan access considering it a security risk to have a PC that they are not absolutely sure is protected by a firewall, virus protection etc, browsing the internet whilst connected to the old corporate net.  If so, you probably can't change it.

WGhen
0
 
LVL 4

Expert Comment

by:pakitloss
ID: 18054798
Yes, uncheck...... the problem is a VPN like a Cisco PIX can not send traffic out the same interface it came in on.
0
 
LVL 4

Expert Comment

by:Trilotech
ID: 18054905
It all comes down to whether you want them to be able to access the internet through their own connection seperate from the VPN traffic or if you want to route the internet traffic THROUGH the vpn connection.

By default, when you create a VPN connection, your VPN connection is set up as your default gateway when it is connected unchecking the default gateway in your VPN settings, as JamesTX10 said, will keep your original default gateway (local modem dsl/cable). This means that only traffic bound for the subnet on which your VPN is a part of will go there and all other traffic will go to you normal internet connection.

This can be good or bad. If they need access to other things across the VPN that gets routed within your office, you will have a problem as all traffic will try and route out your local default gateway.
0
 
LVL 5

Expert Comment

by:WGhen
ID: 18054946
>>> the problem is a VPN like a Cisco PIX can not send traffic out the same interface it came in on

Right, but it wouldn't have to.  The home PC goes directly to the internet for internet destinations and thru the tunnel for VPN access to corporate network.  Whether or not that is allowed is determined by the PIX admin by enabling split-tunnelling or not.  WGhen
0
 
LVL 3

Expert Comment

by:MarkWYnne
ID: 18055018
It is definately best that they get internet access from the office network. Check for issues at that point, when accessing the VPN and successfully connected to the office network, check the internal addresses they are getting from network when connected to VPN. Make sure they can contact the proxy when conected to the office network.
0
 

Author Comment

by:nhftech
ID: 18055399
Thanks for the reponses, I have unchecked the default gateway option as suggested and it didn't work. Will look at the router options later when users are off.
0
 
LVL 4

Expert Comment

by:pakitloss
ID: 18055698
Also what I do is to add the machines I want to access in the host file under %WINDIR%/system32/drivers/etc/hosts so that traffic is directed down the VPN and never tries to go out your cable/dsl gateway. This is good for when you have a multihomed server that resolves on the outside or reaching your exchange server.
0

Featured Post

Limited time offer using promo code EXPERTS30

Designed with a wealth of functionality and convenience, ATEN's new Thunderbolt™ 2 Sharing Switch takes your Thunderbolt setup to the next level. Now through September 15, 2017, Experts Exchange members get 30% off the US7220 on the ATEN USA eShop using promo code EXPERTS30.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I had an issue with InstallShield not being able to use Computer Browser service on Windows Server 2012. Here is the solution I found.
Make the most of your online learning experience.
Viewers will learn how to connect to a wireless network using the network security key. They will also learn how to access the IP address and DNS server for connections that must be done manually. After setting up a router, find the network security…
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…
Suggested Courses
Course of the Month10 days, 21 hours left to enroll

770 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question