Listener start error

Posted on 2006-12-01
Last Modified: 2011-10-03
     Im getting the following error while starting listener on Oracle 8i  (

LSNRCTL> start
Starting /u01/app/oracle/product/8.1.7/bin/tnslsnr: please wait...

TNS-12547: TNS:lost contact
 TNS-12560: TNS:protocol adapter error
  TNS-00517: Lost contact
   Solaris Error: 32: Broken pipe

This is a dev. database and it was down like for months. I took over this db. and brought it is online now but has no listener listening. I dont know as what was done previously with this database( i mean, whether there were any patches applied) or any other work, which might have corrupted the Network conf. files. When i first tried to start the listener i got this error  " lsnrctl: fatal: relocation error: file lsnrctl: symbol nlepeget: referenced symbol not found". I thought it might be  because they have run some patch installation previously and ran the command to make the tnslsnr file again : "make -f install". After running this when i tried to start the listener, im getting the error that i have pasted in the beginning. Following are the environment variables that have been set


The evironment variables are set correctly, solaris file size has been set to unlimited (so, no problem with the listener.log file size). I have searched many documents but did not find any solution. Im requesting you to please provide your suggestion on this. can a relinking of executables work?

Thank you,

Question by:harris2107
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
LVL 11

Assisted Solution

mohammadzahid earned 100 total points
ID: 18055330
Please take a look at the url below: 


Author Comment

ID: 18055664
Thanks but I have already seen that tip, that is why i have already quoted that there is no contention with the file size i.e., 2GB limit and other environment variables. Even the port that has been listed in listener.ora 1521 is not being used by any other applications except the listener. Any help would be appreciated, thanks.
LVL 13

Assisted Solution

anand_2000v earned 100 total points
ID: 18058830
go to listener.ora and find out wheather listener is configured in diff name.

generally if you give Lsnrctl > start,Oracle will look for a default named listener in the name listener,if the istener is configured in diff name it will not fetch the name,so hav a look at listener.ora and if is in diff name then try,

  lsnrctl > start listenername

 else configure a new listener using netmgr or netca and try starting it
Creating Instructional Tutorials  

For Any Use & On Any Platform

Contextual Guidance at the moment of need helps your employees/users adopt software o& achieve even the most complex tasks instantly. Boost knowledge retention, software adoption & employee engagement with easy solution.


Author Comment

ID: 18069237
listener.ora has default name LISTENER. I tried to configure a new listener with netca, but when i issued netca at the command prompt, no GUI (of netca) is coming up(im using putty, any display properties need to set?). So, i edited the listener.ora manually and added a new listener by name DEV1LISTENER and commented out the LISTENER. But even then im not able to start the listener. Below is my listener.ora file and the corresponding errors when i tired to start and (or) reload the listener ( *commented out  the hostname)

$ cat listener.ora
# LISTENER.ORA Configuration File:/u01/app/oracle/product/8.1.7/network/admin/listener.ora
# Generated by Oracle configuration tools.

#      (ADDRESS_LIST =
#        (ADDRESS = (PROTOCOL = TCP)(HOST = host1.test)(PORT = 1521))
#      )
#    )
#  )
           (DESCRIPTION =
              (ADDRESS_LIST =
                  (ADDRESS = (PROTOCOL = TCP) (HOST = host1.test) (PORT = 1521))

    (SID_DESC =
      (SID_NAME = dev1)
      (ORACLE_HOME = /u01/app/oracle/product/8.1.7)
      (GLOBAL_DBNAME = dev1.test1.test2)

The following are the errors that i got after issuing start dev1listener and (or) reload dev1listener from lsnrctl prompt

LSNRCTL> start dev1listener
Starting /u01/app/oracle/product/8.1.7/bin/tnslsnr: please wait...

TNS-12547: TNS:lost contact
 TNS-12560: TNS:protocol adapter error
  TNS-00517: Lost contact
   Solaris Error: 32: Broken pipe

LSNRCTL> reload dev1listener
Connecting to (DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=host1.test)(PORT=1521)))
TNS-12541: TNS:no listener
 TNS-12560: TNS:protocol adapter error
  TNS-00511: No listener
   Solaris Error: 146: Connection refused

When i issued just reload (with out dev1listener parameter), i got following error

LSNRCTL> reload
Connecting to (ADDRESS=(PROTOCOL=ipc)(KEY=PNPKEY))
TNS-12541: TNS:no listener
 TNS-12560: TNS:protocol adapter error
  TNS-00511: No listener
   Solaris Error: 2: No such file or directory
Connecting to (ADDRESS=(PROTOCOL=tcp)(PORT=1521))
TNS-12541: TNS:no listener
 TNS-12560: TNS:protocol adapter error
  TNS-00511: No listener
   Solaris Error: 146: Connection refused

Im new to Oracle and Solaris, im trying alot but im not able to get over this. Please help.

LVL 77

Accepted Solution

slightwv (䄆 Netminder) earned 300 total points
ID: 18070133
First:  It's been years since I've been on UNIX and about as long ago for 8.1.7 so if this goes outside a simple Oracle Network issue, you'll probably lose me pretty quick.

Just for grins, use the IP address of the server instead of it's hostname (replace with the real IP address):
                (ADDRESS = (PROTOCOL = TCP) (HOST = host1.test) (PORT = 1521))
                (ADDRESS = (PROTOCOL = TCP) (HOST = (PORT = 1521))

Author Comment

ID: 18070934
I had to relink the lsnrctl executable (and changed the HOST to IP address). Thanks anyway.

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

This article started out as an Experts-Exchange question, which then grew into a quick tip to go along with an IOUG presentation for the Collaborate confernce and then later grew again into a full blown article with expanded functionality and legacy…
How to Unravel a Tricky Query Introduction If you browse through the Oracle zones or any of the other database-related zones you'll come across some complicated solutions and sometimes you'll just have to wonder how anyone came up with them.  …
This video shows how to Export data from an Oracle database using the Datapump Export Utility.  The corresponding Datapump Import utility is also discussed and demonstrated.
Via a live example, show how to restore a database from backup after a simulated disk failure using RMAN.

734 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question