Solved

Cisco Help

Posted on 2006-12-01
11
188 Views
Last Modified: 2011-04-12
Hi, I have currently gotten some addtional IP addresses and was told by my ISP to configure the router accordingly. They also stated that they added the new IP's to my BGP session. I could show you a copy of my config if that helps.

Thank you for the help.
0
Comment
Question by:dgerbergss
  • 5
  • 5
11 Comments
 
LVL 50

Expert Comment

by:Don Johnston
ID: 18055777
Yes. Please post your config without passwords.
0
 

Author Comment

by:dgerbergss
ID: 18055796

One addtional note is they stated:
non-portable netblock has been assigned to account number wcomw0h29113
Not sure if that makes a difference or not.


interface FastEthernet0/0
 ip address 10.0.0.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 description to GSS Seventh Ave
 ip address 208.255.99.121 255.255.255.248
 duplex auto
 speed auto
!
interface Serial0/0/0
 no ip address
 encapsulation frame-relay IETF
 logging event subif-link-status
 logging event dlci-status-change
 no fair-queue
 frame-relay lmi-type ansi
!
interface Serial0/0/0.500 point-to-point
 description to UUNet CID W0H29113
 bandwidth 1536
 ip address 157.130.18.54 255.255.255.252
 frame-relay interface-dlci 500
!
interface Serial0/1/0
 no ip address
 encapsulation frame-relay IETF
 logging event subif-link-status
 logging event dlci-status-change
 frame-relay lmi-type ansi
!
interface Serial0/1/0.500 point-to-point
 description to UUNet CID W0K84694
 bandwidth 1536
 ip address 157.130.18.126 255.255.255.252
 frame-relay interface-dlci 500
!
router bgp 7046
 no synchronization
 bgp log-neighbor-changes
 network 208.255.99.120 mask 255.255.255.248
 network 208.255.99.120 mask 255.255.255.252
 network 208.255.99.124 mask 255.255.255.252
 redistribute connected
 neighbor 157.130.18.53 remote-as 701
 neighbor 157.130.18.53 route-map to-wcomw0h29113 out
 neighbor 157.130.18.125 remote-as 701
 neighbor 157.130.18.125 route-map to-wcomw0k84694 out
 no auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 157.130.18.53
ip route 0.0.0.0 0.0.0.0 157.130.18.125
ip route 208.255.99.120 255.255.255.248 FastEthernet0/1
ip route 208.255.99.120 255.255.255.252 FastEthernet0/1
ip route 208.255.99.124 255.255.255.252 FastEthernet0/1
!
!
ip http server
no ip http secure-server
!
!
ip prefix-list 1 seq 5 permit 208.255.99.120/29
ip prefix-list 1 seq 7 permit 208.255.99.120/30
ip prefix-list 1 seq 10 deny 0.0.0.0/0 le 32
!
ip prefix-list 2 seq 5 permit 208.255.99.124/30
ip prefix-list 2 seq 10 deny 0.0.0.0/0 le 32
logging trap debugging
access-list 10 permit 208.255.99.120 0.0.0.7
route-map to-wcomw0h29113 permit 10
 match ip address prefix-list 1
!
route-map to-wcomw0h29113 permit 15
 match ip address prefix-list 2
 set metric 10
!
route-map to-wcomw0h29113 deny 20
!
route-map to-wcomw0k84694 permit 10
 match ip address prefix-list 2
!
route-map to-wcomw0k84694 permit 20
 match ip address prefix-list 1
 set metric 10
!
route-map to-wcomw0k84694 deny 30
!
!

0
 
LVL 12

Expert Comment

by:pjtemplin
ID: 18056317

no ip route 208.255.99.120 255.255.255.248 FastEthernet0/1
no ip route 208.255.99.120 255.255.255.252 FastEthernet0/1
no ip route 208.255.99.124 255.255.255.252 FastEthernet0/1
ip route 208.255.99.120 255.255.255.248 null0 250
ip route 208.255.99.120 255.255.255.252 null0 250
ip route 208.255.99.124 255.255.255.252 null0 250
ip route x.x.x.x y.y.y.y <destination next-hop>
ip route x.x.x.x y.y.y.y null0 250
!
! if you want the new prefix to prefer to come in via 0h29113
ip prefix-list 1 seq 8 permit x.x.x.x/z
!
! if you want the new prefix to prefer to come in via 0k84694
ip prefix-list 2 seq 8 permit x.x.x.x/y
!
router bgp 7046
 network x.x.x.x mask y.y.y.y
 no redist conn
!
0
Portable, direct connect server access

The ATEN CV211 connects a laptop directly to any server allowing you instant access to perform data maintenance and local operations, for quick troubleshooting, updating, service and repair.

 

Author Comment

by:dgerbergss
ID: 18056586
If I do the no IP route to the 208.255.99.120 I will loose those subnets?

They IP route x.x.x.x y.y.y.y is the new network?
The next hop would be my fast ethernet 0/1?

The IP prefix-list 2 seq 8 permit x.x.x.x/y do I place the new network?

And thank you for your help!!!
0
 
LVL 12

Expert Comment

by:pjtemplin
ID: 18056613
I'm rethinking my previous hints, and I think you want to leave the static routes as is (i.e. don't replace them with routes to null0).  

The IP route x.x.x.x y.y.y.y would be the new network.  The next hop can't be "Fast0/1" unless that address is natively bound there; you'll need to let us know how you're going to deploy the new subnet so we can fine-tune any particulars.

You'll have to place the new network in one prefix-list or the other.  It'll be x.x.x.x/z, where z is the CIDR size of the network (just like your other prefix-list entries).
0
 

Author Comment

by:dgerbergss
ID: 18056691
I just want to be able to recieve the IP's. SO I guess the next hop would be outbound correct?

As far the prefix This is the block I got: 65.209.71.236/30
0
 
LVL 12

Expert Comment

by:pjtemplin
ID: 18056723
If you just want to receive them, do the null route for now.
0
 

Author Comment

by:dgerbergss
ID: 18056739
Sorry now I'm confused. Were does the null route go?
0
 
LVL 12

Expert Comment

by:pjtemplin
ID: 18057073
ip route 65.209.71.236 255.255.255.252 null0 250

It goes nowhere, but makes the prefix exist in your RIB so that BGP will announce it and you will receive the traffic.
0
 

Author Comment

by:dgerbergss
ID: 18057095
ok, so that is all I need to put in? or do I still need this part?

if you want the new prefix to prefer to come in via 0h29113
ip prefix-list 1 seq 8 permit x.x.x.x/z
!
! if you want the new prefix to prefer to come in via 0k84694
ip prefix-list 2 seq 8 permit x.x.x.x/y
!
router bgp 7046
 network x.x.x.x mask y.y.y.y
 no redist conn
0
 
LVL 12

Accepted Solution

by:
pjtemplin earned 500 total points
ID: 18057112
You still need that part; keep in mind you'll have to choose WHICH prefix-list entry to make.
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Port forwarding 14 173
Can Cisco resolve internet address internally 4 52
adjusting startup config 6 23
Cisco EIGRP Network 6 20
It happens many times that access list (ACL) have to be applied to outgoing router interface in order to limit some traffic.This article is about how to test ACL from the router which is not very intuitive for everyone. Below scenario shows simple s…
Creating an OSPF network that automatically (dynamically) reroutes network traffic over other connections to prevent network downtime.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

839 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question