Solved

Networking a PC and Laptop.. not as simple as it sounds

Posted on 2006-12-01
14
500 Views
Last Modified: 2013-11-09
Hi, Heres my Situation:

first i'll explain the physical topology of my network (poor paint picture below)

http://www.dracata.net/images/physical_topology.bmp

Centrally there is a four-port wireless router

the family computer is connected directly via ethernet cable to it, and is a non-issue

in my office there is my Main PC and my laptop, both connect wirelessly to the router for internet access

because of the distance/wall density of my office the wireless signal is low (hence low speeds) and even if the wireless network was running at full bandwidth, i want to take advantage of the gigabit ethernet speeds that my main pc and laptop posess

so my main PC and laptop are connected via gigabit ethernet ports

My Question:
Firstly, i just want the main pc connected to the laptop via ethernet, to take advantage of the gigabit ethernet speeds (transfering files, streaming etc)

i also still want both to connect to the wireless router to have internet access (or just one if its possible for the other to gain internet access through the one)

ALSO

How can i setup a local full-share network between my main PC and laptop, so that they each have full access to each others hard drives and resources

BUT

not share anything through the wireless network

The Problem:

currently the main pc and laptop are connected via wireless(g) to the router, the router is running dhcp and both are set to automatic, the router is running a 192.168.1.1 network.

the main pc and laptop are also connected via gigabit ethernet

i have given the main pc the network addresses:

ip 10.0.0.1
sub 255.255.255.0
gate 192.168.1.1 (router)
dns 192.168.1.1 (router)

and the laptop:

ip 10.0.0.2
sub 255.255.255.0
gate 192.168.1.1 (router)
dns 192.168.1.1 (router)

now, both connect to the internet fine

but, when transfering/accessing files from the laptop, to the main pc - its very, very slow - as if its using the wireless network to transfer files (speed of around 5.5-11mbps)

but when transfering/accessing files from the main pc to the laptop, its fairly, if not very fast - so i *think* it must be using the ethernet

i've done everything within my knowledge, which is obviously not enough, hence why i am asking you geniuses!

hope you can help with my problems and apologies for the large post

Rob.
0
Comment
Question by:seremaz
  • 5
  • 3
  • 2
  • +4
14 Comments
 

Author Comment

by:seremaz
ID: 18057452
Just to clarify, the network addresses above are what i have given to the Ethernet connection on both machines (obviously)
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 18057832
>so my main PC and laptop are connected via gigabit ethernet ports
How are you connecting them together? You should be using a GigabitE crossover which is very different from a "standard" Ethernet crossover cable.
0
 

Author Comment

by:seremaz
ID: 18057878
im pretty sure its just a standard cat5e cable, either way, they auto-sense and downspeed to 100mbps no?
0
Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

 
LVL 79

Expert Comment

by:lrmoore
ID: 18057896
Maybe, maybe not. Some NIC's do and most do not when connected to each other.
Try a regular Ethernet crossover and manually set both systems to 100/half-duplex
0
 

Author Comment

by:seremaz
ID: 18057916
i did try that earlier, but to no avail :/

i've just tested it again, on 100/full and since playing with the settings both machines access each other very slow.. so definatley over the wireless network, i just can't understand it
0
 

Author Comment

by:seremaz
ID: 18057917
still accessing slowly after i changed the settings back to how they were..
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 18057961
If I get you, your Wired NIC has 10.0.0.x IP address and your wireless NIC has 192.168.1.x IP address

Can you post result of "route print" from both?

Try adding a LMHOSTS file for each system in both PC's.

10.0.0.1 <tab> MAINPC
10.0.0.2 <tab> LAPTOP

After you create the files, run nbtstat -R
Then try connecting using name
Start/ Run / \\MAINPC\share
0
 
LVL 2

Expert Comment

by:eric_bender
ID: 18057992
Are you connecting the NICS's directly to each other......If so you should be using a cross over style cable.  Otherwise you are going to be getting collisions as they try to send and recieve on the same wire pairs.
0
 
LVL 2

Expert Comment

by:eric_bender
ID: 18058002
When connecting with wired installations you should review the "pin outs" for a Cat5/Cat5e Cable..... you have 8 pins, see this link http://www.tokind.com/cat5.html 

If that is already what you have then the issue may very well be that the gateway and dns are both the router...
0
 
LVL 3

Expert Comment

by:JRockSolid
ID: 18058165
I have drawn a diagram mainly because i was bored, but secondly because I thought it would help me explain myself.

http://pogofiles.gotdns.com/downloads/EEpic.bmp

Just two routes need to be made and i think the syntax is right in the diagram.
This should make all requests for the network 192.168.0.x trvel out to the router and all traffic bound for the 10.0.0.x network flow over the gigabit link.
NOTE: Cat 5e cable is made to handle gigabit but true gig speeds can ONLY be performed on cat6 cable.

If it doesnt help then maybe you can atleast get some joy from the pic. :]

NOTE: Pic drawn with networknotepad. Available at networknotepad.com

0
 
LVL 2

Expert Comment

by:atomicfire001
ID: 18058423
To the previous poster:
Gigabit networking design allows for conventional straight through Cat5e to work as both straight and cross connections. In other words, as long as at least one PC has a gigabit interface, you don't need a special cable to do a crossover connection. For more information check here:
http://www.sql-server-performance.com/jc_gigabit.asp

To the OP:
The easiest way to do this would be to have the PC on wireless, and then enable internet connection sharing on the wired interface. Then just plug the laptop into the wired interface, and configure it all automatically with DHCP. No fuss, should work right away.

0
 
LVL 4

Accepted Solution

by:
Trilotech earned 500 total points
ID: 18058554
Let me throw in a couple of cents worth.

As long as you know your wired network IS working (test it with the wireless turned off) then you can adjust you adapter bindings to cause your wired connection to be the primary communicator and the wireless to be the secondary. Go to "Control Panel" --> "Network Connections". At the top click "Advanced" and select "Advanced Settings". You will see your connections listed (wireless and wired, etc). You can put these in the order you would like you computer to "try" local communication. So move the wired connection to the top.

Now to NOT allow sharing on the wireless side you have a couple of options. The easiest would be to right click on your wireless connection in "Network Connections" and choose "Properties". Take the check mark OFF of "File and Printer Sharing for Microsoft Networks".

Now you have disabled sharing on the wireless card and made your wired connection your default for local traffic. Leave the wired connections gateway blank. Put a gateway address in (or DHCP) for your wireless and all internet traffic will be routed there.

That should do ya.
0
 
LVL 10

Expert Comment

by:snerkel
ID: 18059103
Firstly on the gigabit network cards delete the entries in default gateway and DNS these aren't needed for this type of connection and can confuse windows routing.

When you access the other PC don't use the network name, use the IP address. To do this open the run box and type

\\10.0.0.1    

or

\\10.0.0.2
0
 

Author Comment

by:seremaz
ID: 18059940
Thanks for all of your above comments, all have been useful - but it was trilotech that pointed out what i needed/wanted to know, the wireless connection was simply the primary connection hence it defaulting to that for general network traffic - thankyou very much all!
0

Featured Post

Courses: Start Training Online With Pros, Today

Brush up on the basics or master the advanced techniques required to earn essential industry certifications, with Courses. Enroll in a course and start learning today. Training topics range from Android App Dev to the Xen Virtualization Platform.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Layer 2 versus layer 3 10 86
WiFi Router device supports GPON! 3 54
How to Create Separate Guest WiFi VLAN on Netgear R8000 19 51
Cisco WLAN 5520 licensing 10 33
Short answer to this question: there is no effective WiFi manager in iOS devices as seen in Windows WiFi or Macbook OSx WiFi management, but this article will try and provide some amicable solutions to better suite your needs.
I had an issue with InstallShield not being able to use Computer Browser service on Windows Server 2012. Here is the solution I found.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Internet Business Fax to Email Made Easy - With  eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, f…

785 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question