[2 days left] What’s wrong with your cloud strategy? Learn why multicloud solutions matter with Nimble Storage.Register Now

x
?
Solved

Remote Desktop Client 6 - won't remember domain or local logon

Posted on 2006-12-01
9
Medium Priority
?
8,631 Views
Last Modified: 2012-08-14

I recently updated to RDC6 and it doesn't have a field for remembering domain so where I used to be able to just double click my icon and it would log in automatically, it now starts to log in and then fails because it defaults to a local (this computer) login, where I have to click OK on the error and then re-enter my password and change it to domain login before I get to my TS desktop (win2000 server). Is anyone aware of a solution to this problem?
Thanks
-Chuck
0
Comment
Question by:chuckrox
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 3
9 Comments
 
LVL 10

Expert Comment

by:MATTHEW_L
ID: 18064501
Open your saved connection file, should be something.rdp in notepad.  You can then edit the lines that you want.  There are lines for username, domain etc.

Here is an example of the things you need to edit.  Let me know if you need some more help.

full address:s:REMOTECOMPUTER
username:s:USERNAME
domain:s:DOMAINNAME
0
 
LVL 10

Expert Comment

by:MATTHEW_L
ID: 18064553
Here is the complete file:  save as a file.rdp change a couple of the lines and it will auto log you in.  Change any of <> of course remove the brackets and type your own info.

screen mode id:i:2
desktopwidth:i:1024
desktopheight:i:768
session bpp:i:16
winposstr:s:0,3,0,0,800,600
full address:s:<remotecomputer>
compression:i:1
keyboardhook:i:2
audiomode:i:0
redirectdrives:i:0
redirectprinters:i:0
redirectcomports:i:0
redirectsmartcards:i:0
displayconnectionbar:i:1
autoreconnection enabled:i:1
username:s:<username>
domain:s:<domainname>
alternate shell:s:
shell working directory:s:
disable wallpaper:i:0
disable full window drag:i:0
disable menu anims:i:0
disable themes:i:0
disable cursor setting:i:0
bitmapcachepersistenable:i:1
password <cleartextpassword>

0
 
LVL 10

Expert Comment

by:MATTHEW_L
ID: 18064570
You can also type in your credentials in the box that comes up and say save at the bottom.  I have tried a few of these as I had the same troubles with teh new RDP connection.  Either works.  I have opted myself to just setup the connection in the new rdp connection, save it.  Then the first time you use it, you must enter credentials, and say save.  Seems to work fine.
0
Get your Disaster Recovery as a Service basics

Disaster Recovery as a Service is one go-to solution that revolutionizes DR planning. Implementing DRaaS could be an efficient process, easily accessible to non-DR experts. Learn about monitoring, testing, executing failovers and failbacks to ensure a "healthy" DR environment.

 
LVL 2

Author Comment

by:chuckrox
ID: 18069580
When I viewed the RDP file in notepad I didn't have the following lines:
username:s:<username>
domain:s:<domainname>
and when I added them and connected I still had the same problem. Also when I re-edited and saved in RDP connection, then went back and looked with notepad, the lines I added were gone. Here's my RDP file exactly:

***START RDP FILE***
screen mode id:i:1
desktopwidth:i:1024
desktopheight:i:768
session bpp:i:16
winposstr:s:0,3,0,0,800,600
full address:s:COMPYNAME
compression:i:1
keyboardhook:i:2
audiomode:i:2
redirectdrives:i:0
redirectprinters:i:0
redirectcomports:i:0
redirectsmartcards:i:0
displayconnectionbar:i:1
autoreconnection enabled:i:1
alternate shell:s:
shell working directory:s:
password XXXXXXX
disable wallpaper:i:1
disable full window drag:i:1
disable menu anims:i:1
disable themes:i:1
disable cursor setting:i:0
bitmapcachepersistenable:i:1
redirectclipboard:i:1
redirectposdevices:i:0
drivestoredirect:s:
authentication level:i:0
prompt for credentials:i:0
negotiate security layer:i:1
remoteapplicationmode:i:0
allow desktop composition:i:0
allow font smoothing:i:0
gatewayhostname:s:
gatewayusagemethod:i:0
gatewaycredentialssource:i:4
gatewayprofileusagemethod:i:0
***END RDP FILE***

BTW my client RDP version is 6.06.6000

Thanks
-Chuck
0
 
LVL 10

Expert Comment

by:MATTHEW_L
ID: 18070278
When it comes up with credentials try selecting the box to save them.  Also, make sure that prompt for credentials:i:0 is set in your RDP file.  Not set to 1, yours is fine now.
0
 
LVL 2

Author Comment

by:chuckrox
ID: 18070604
I don't think the problem is my saved username/password, but instead its the fact that it always defaults to a local computer login and not a domain login. Is there any other way I can force the RDC to domain login?
0
 
LVL 10

Accepted Solution

by:
MATTHEW_L earned 1000 total points
ID: 18070732
That is part of your username.  Either add the domain:s:domainname in your rdp file.  Or when you authenticate use domainname\username
password

And save the credentials.  This should work, and specify the domainname to use.
0
 
LVL 2

Author Comment

by:chuckrox
ID: 18070869
After experimenting I got domain\username working in the RDC properties and was able to save it. Sorry for all the grief. I think part of my problem was trying to use domain.local instead of just domain. Thanks again.
-Chuck
0
 

Expert Comment

by:Julie Lyons
ID: 37408187
I actually have to add a comment because my 2003 R2 server had the same issue. Turns out, however, that none of the scripts above worked and it was a local group policy setting from a previous administrator.
"Local Computer Policy=>Computer Configuration=>Administrative Templates=>Terminal Services=>Encryption And Security=>Always prompt client for password upon connection" was set to enabled.  Simply disabled and I was able to save domain/username and password and successfully connected without re-entering again.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

#Citrix #XenDesktop #POC #Proof-of-concept
Citrix XenDesktop 7.6 Citrix Policies Disable Peripherals
How to install and configure Citrix XenApp 6.5 - Part 1. In this video tutorial we have explained step by step installation of Citrix XenApp 6.5 Server on Windows Server 2008 R2 is explained in this video. We have explained the difference between…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

656 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question