Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

Troubleshooting
Research
Professional Opinions
Ask a Question
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

troubleshooting Question

Network booting

Avatar of petepalmer
petepalmer asked on
LinuxStorage SoftwareLinux Distributions
25 Comments1 Solution545 ViewsLast Modified:
Hi,

When booting a linux box from the network, everything goes fine with PXE. However the machine has two network cards. The problem is, the card we boot from that has the PXE support isnt the one that Linux picks up - and so it tries to mount the NFS shares etc using the sceond network card - which of course fails.

So the question really is - how at boot time say as a kernel parameter - can you specify which device should be which label i.e eth0.

Thanks in advance!



ASKER CERTIFIED SOLUTION
Avatar of DarthMod
DarthModFlag of United States of America image

Our community of experts have been thoroughly vetted for their expertise and industry experience.

Commented:
This problem has been solved!
Unlock 1 Answer and 25 Comments.
See Answers