troubleshooting Question

Troubleshooting a performance issue: new SATA drives only getting 7MB/s write

Avatar of stev0931
stev0931 asked on
HardwareStorage
27 Comments11 Solutions838 ViewsLast Modified:
I have an HP ML350 G5 server using an E200i RAID controller w/ 128MB cache and a BBWC.  I have 6 SATA 250GB 7200 RPM drives in a hot-plug drive cage.  This is what I'm getting:

When I set the cache to 0% read / 100% write and perform sequential reads, I get 50MB/s (~400mbps)
When I set the cache to 100% read / 0% write and perform sequential writes, I get 7MB/s (~50mbps)
When I set the cache to 50% read / 50% write, I get good read and write performance

I'm assuming that either:
1) All 6 drives are bad (not very likely)
2) Something's wrong with the integrated E200i controller

I have 3 questions:
1) Are there any other possibilities than above?
2) What is most likely wrong?
3) Would purchasing a P400 RAID controller (411064-B21) probably solve the problem?  If yes, can I hook up the 6-drive hot-plug cage to the controller?
ASKER CERTIFIED SOLUTION
Duncan Meyers

Our community of experts have been thoroughly vetted for their expertise and industry experience.

Join our community to see this answer!
Unlock 11 Answers and 27 Comments.
Start Free Trial
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 11 Answers and 27 Comments.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros