troubleshooting Question

Exchange Re-installation problem

Avatar of cybera
cyberaFlag for Singapore asked on
SBS
15 Comments1 Solution752 ViewsLast Modified:
Hi Experts,

I am currently having problem with re-installation.
When trying to run from my CD, SBS2003 Disc 2, Exchange server, they prompt me for CD key which i do not have. I tried using my SBS 2003 serial but error appear stating that i am using an incorrect cdkey.

When i try to use the add/remove program to re-install the Exchange, an error occur:
Multiple components cannot be assigned to the requested Action(s):
To install the first Exchange server in a domain, or to run setup in /forestprep mode, you must be an exchange full administrator at the organization level. You must use and account that has been granted the Full Exchange Administrator Role on the exchange organization using the Exchange Administrative delegation Wizard.

I have run Exchange system manager, and tried to run delegate permissions. Error appeared:
There is no such object on the server
Facility: win32
ID no: c0072030
Exchange system manager

After this error appears, i see the add/remove buttons greyed out and i cannot add any users to delegate.

I beleive I have screwed up the initial installation of the exchange, hoping that i can re-install it. I have enabled viewing of permissions through registry key changes, and remove all DENY permissions for ADministrator account. Yet i still cannot run the re-installation.

My last resort, is to do a full re-installation of Windows 2003 Server. But i hope i can try to resolve it by today. and if so, i can skip the hassle of re-installing everything...

Steps I have taken and procedures:

1) tried to run re-installation
2) error state that there is no permissions.
3) tried to delegate permissions
4) error stating cannot find objects
5) tried to run setup /forestprep, prompt for cDkey which i dont have.
6) tried to enable permissions manually on exchange system manager, but still cannot run the re-installation.

background notes:
exchange were having big problem. So i tried to remove and reinstall it.
followed instructions to remove exchange through add/remove program, then restarted server.
After that, install Exchange again. through the installation, an error about mapi32.dll occured.
installation completed, but with errors.

After that, i followed instructions to rename mapi32.dll to .old, and load a fresh copy from the install disc. ESM then was able to run properly. However, the system still is not able to re-install exchange.

Any solutions that you all know of that can help me?

thanks!
cybera
ASKER CERTIFIED SOLUTION
Join our community to see this answer!
Unlock 1 Answer and 15 Comments.
Start Free Trial
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 1 Answer and 15 Comments.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros