troubleshooting Question

problem with sqlcmd

Avatar of andieje
andieje asked on
Microsoft SQL Server
5 Comments1 Solution2079 ViewsLast Modified:
hi

on my machine at home i can run this command without problem

sqlcmd -S UCHOOSEWEB\SQLEXPRESS -i C:\TRANSFORMTVDATA.SQL -O C:\OUT.TXT

a console window appears and displays messages such as 'changing database context" and '-o is obsolete' and the sql in the file is executed

if i run the same command on my web server a console window opens and the closes immediately. It seems like there is something wrong with the sqlcmd on the web server. Naturally i am using the appropriate machine names on the different computers.

If i type sqlcmd -S UCHOOSEWEB\SQLEXPRESS a console window opens with '>1' as a prompt.

why cant i run the command on the web server?

thanks a lot
andrea

thanks
andrea
ASKER CERTIFIED SOLUTION
devsolns

Our community of experts have been thoroughly vetted for their expertise and industry experience.

Join our community to see this answer!
Unlock 1 Answer and 5 Comments.
Start Free Trial
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 1 Answer and 5 Comments.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros