troubleshooting Question

Perl in-place edit for shared file

Avatar of tcvinod
tcvinod asked on
Perl
9 Comments1 Solution4510 ViewsLast Modified:
Hi,
I tried to perform perl inline edit to replace a string.
The file I tried to modify is shared through NAS drive through different platforms (UNIX & WINDOWS).
But, I can pretty much edit the file using VI editor in UNIX.

When I try the command it gives me the following error,
"Can't do inplace edit on test.txt: Not owner."

The commands I tried were,
perl -pi -e 's/CLAD/BKOC/g' test.txt
perl -pi.bak -e 's/CLAD/BKOC/g' test.txt

Are inline edits possible only for the owner of the file, even though groups and others have full write access?
I tried to search a resolution, but with no luck.
Could anyone please advise me?
ASKER CERTIFIED SOLUTION
mjcoyne

Our community of experts have been thoroughly vetted for their expertise and industry experience.

Join our community to see this answer!
Unlock 1 Answer and 9 Comments.
Start Free Trial
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 1 Answer and 9 Comments.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros