We help IT Professionals succeed at work.

Remote Access Blocked on Windows Server 2003

genesissi
genesissi asked
on
264 Views
Last Modified: 2010-04-18
I am setting up a Windows Server 2003 machine for remote access development purposes.
I have configured the following:
   Enable Remote Desktop
   Attempted to login as Administrator

The machine is not a domain controller, the app developing won't allow it, so the administrator is local.

What else am I missing?
Comment
Watch Question

is the server a member of a domain?
what error are you getting?

Author

Commented:
The server is not a member of a domain.  
It is a standalone on its own static IP behind a comcast modem.
what error are you getting?
also, can you connect to it internally (if it has an internal IP)?
if you can connect to it internally and not externally then it is a firewall/router issue.  Make sure that port 3389 is allowed/forwarded on your router/firewall.

also run 'netstat -an' from a command window on the server and make sure port 3389 is listening.

Author

Commented:
I ran netstat -an, and yes port 3389 is listening.
>>I ran netstat -an, and yes port 3389 is listening.
well that means that remote desktop is working on that server.

third time---WHAT ERROR?
second time-- can you connect to it internally (if it has an internal IP)?

Author

Commented:
Sorry, you'd think I didn't really want the answer;)

Error: (When attempting to RDP into server from outside)
"Remote Desktop Disconnected
This computer can't connect to the remote computer.
Try connecting again.  If the problem continues, contact the owner of the remote computer or your network administrator."

Internal Connectivity:
The server resides in an office by itself with a comcast connection.  No other computers.
I might be able to get a laptop to test this though.

Note:
I will post an ipconfig /all soon to see if I am missing anything.

Author

Commented:
I found A LOT of information when I called Comcast to confirm some information.
   1. The static IP file they download to the modem had been "lost" -> so it was corrected.
   2.  And they assign an entire lot of static IP info -> IP, Subnet, Gateway, Prim.DNS, Sec.DNS
So I now have all of that in place.

Here is my ipconfig /all: (NOTE: I have change the literal IP's)

Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Broadcom BCM5708C NetXtreme II GigE (NDIS
 VBD Client)
   Physical Address. . . . . . . . . : 00-18-8B-40-FE-8C
   DHCP Enabled. . . . . . . . . . . : No
   IP Address. . . . . . . . . . . . : 90.70.150.220
   Subnet Mask . . . . . . . . . . . : 255.255.255.252
   Default Gateway . . . . . . . . . : 90.70.150.221
   DNS Servers . . . . . . . . . . . : 78.86.59.88
                                       78.86.59.146

C:\Documents and Settings\Administrator.SERVER1>
The following may be relevant as well:
  My Computer -> Properties -> Computer Name tab
                                                             Full Computer Name: SERVER1.domain.local
                                                             Workgroup: WORKGROUP
I originally DCPromo'd this machine to make a domain controller, but, later DCPromo'd it again to demote as I found the key application would not reside on a domain controller.

Author

Commented:
I also logged into our Comcast SMC modem and configured Port Forward for Port 3389.

Author

Commented:
When entering in the information on a WinXP machine for the RDP dialog, I seem unsure what I should put as the 'Domain'.

Am I able to RDP into this machine if it is in a WORKGROUP and not part of a domain?

Author

Commented:
I called Comcast back to confirm Router/Port Forward configuration...good thing:
I was given an entirely different configuration info report, so here is my 'ipconfig /all'

Microsoft Windows [Version 5.2.3790]
(C) Copyright 1985-2003 Microsoft Corp.

C:\Documents and Settings\Administrator.DEVELOPMENT1>ipconfig /all

Windows IP Configuration

   Host Name . . . . . . . . . . . . : DEVELOPMENT1
   Primary Dns Suffix  . . . . . . . : name.local
   Node Type . . . . . . . . . . . . : Unknown
   IP Routing Enabled. . . . . . . . : Yes
   WINS Proxy Enabled. . . . . . . . : No
   DNS Suffix Search List. . . . . . : name.local

Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Broadcom BCM5708C NetXtreme II GigE (NDIS
 VBD Client)
   Physical Address. . . . . . . . . : 00-18-8B-40-FE-8C
   DHCP Enabled. . . . . . . . . . . : No
   IP Address. . . . . . . . . . . . : 10.1.10.2
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 10.1.10.1
   DNS Servers . . . . . . . . . . . : 68.87.85.98
                                       68.87.69.146

C:\Documents and Settings\Administrator.DEVELOPMENT1>

I also wanted to confirm I was seeing what I should be seeing on the 'netstat -an':
   TCP   0.0.0.0:3389   LISTENING
   Q? Should this be 10.1.10.2:3389?
I wonder if you are not part of domain, why would you see the dropdown list called "domain".
Anyways, in domain box, select the local server name then you are logged as local admin.

Author

Commented:
What a headache this one was, but, problem resolved.

If you look on the ipconfig screen it shows the user as: 'Administrator.DEVELOPMENT1'
DEVELOPMENT1 is the Computer Name.
So when attempting to login, I entered Administrator.DEVELOPMENT1 as the user name, left the domain blank, and got in.

I wonder if it had this because I had dcpromo'd to promote and then again to demote (the app installing can't go on a DC).

Anyhow, thanks for all the support it has been greatly appreciated.  Pressing on!
Commented:
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION

Gain unlimited access to on-demand training courses with an Experts Exchange subscription.

Get Access
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Empower Your Career
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.