We help IT Professionals succeed at work.

Non Existing  .net framework conflict

thejohnoshea
thejohnoshea asked
on
254 Views
Last Modified: 2010-05-18
OK, I had to write a consule app to automate a file upload system but when I tried to deploy it I am getting the strangest error.

To run this application, you first must install one of the following versions of the .net framework:
V2.0.50727
contact your application publisher for instructions about obtaining the appropraite version of the .net framework.

the strange part is the server is running v2.0.50727. I've deployed two web app and two other consule app (all VB) written with the same verision of Miscrosoft Visual studio 2005 and they are all working fine.
Why does this one app think it is on a server with the wrong framework?
Comment
Watch Question

Author

Commented:
any ideas?
Commented:
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION

Author

Commented:
Ok, that didn't help but the answer was simple stupid. I was using a citirx session to access the server because i was at a remote site. the Citrix server was using an old framework. Sorry for the stupid question. I'm giving points anyway because JonMny post did help me realize my mistake.
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.