We help IT Professionals succeed at work.

How do I set up multiple static IP addresses on a Cisco ASA 5505?

stev0931
stev0931 asked
on
2,424 Views
Last Modified: 2013-11-16
How do I set up multiple static IP addresses on a Cisco ASA 5505?  I've done an sh run below.  I want all internal traffic to go out on X.X.1.199 and all outside traffic that needs to be forwarded inside (like SMTP) to only be able to come in on X.X.1.200.  To make things even more complicated, I also want to accept VPN connections only on X.X.1.198.

I've done a sh run below to show my current configuration.  I am trying to forward a number of ports, including smtp.  I am used to the PIX 506, so I tried to enter commands in with that background.  I feel that I'm very close, but there's something somewhere catching me.  What do I need to do to get smtp to forward?

asai(config)# sh run
: Saved
:
ASA Version 7.2(2)
!
hostname XXXXX
domain-name XXXXXXXXXX
enable password XXXXXXXXXXXXXXX encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 10.1.1.1 255.0.0.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address X.X.1.200 255.255.255.0
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd XXXXXXXXXXXXXXXXXXXX encrypted
ftp mode passive
dns server-group DefaultDNS
 domain-name XXXXXXXXXXXXXXXXX
access-list inside_access_in extended permit icmp any any
access-list inside_access_in extended permit ip any any
access-list outside_access_in extended permit icmp any any
access-list outside_access_in extended permit tcp any interface outside eq smtp
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
icmp permit any inside
icmp deny any outside
asdm image disk0:/asdm-522.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) tcp X.X.1.200 smtp 10.1.1.200 smtp netmask 255.255.2
55.255
access-group inside_access_in in interface inside
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 X.X.76.1 1
timeout xlate 16:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
telnet 0.0.0.0 0.0.0.0 inside
telnet timeout 15
ssh timeout 5
console timeout 0

!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:XXXXXXXXXXXXXXXXXXXXXXXXXXX
: end
asai(config)#
Comment
Watch Question

Commented:
>>>>>static (inside,outside) tcp X.X.1.200 smtp 10.1.1.200 smtp netmask 255.255.255.255
do you have any webserver running in the background ??
then try port forwarding http requests to that by this command

static (inside,outside) tcp X.X.1.200 80 10.1.1.200 80 netmask 255.255.255.255

and access the serbice from outside by http://X.X.1.200:80 or simply http://X.X.1.200 if this works evrything should be fine, change it back to the smtp CLI

your port forwarding command seemed to be right !


Systems Architect
CERTIFIED EXPERT
Top Expert 2008
Commented:
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION

Author

Commented:
lrmoore,

I think that what you're suggesting solves my problem, but I don't quite understand.  Let me see if I can clarify...

interface Vlan2
     ip address X.X.1.198 255.255.255.0

interface vlan2 can only have one IP address, which we can change to X.X.1.198 above.  All VPN connections must come in on this IP address and all outgoing traffic will exit with this IP address.  We can, however, set multiple globals on the outside:

global (outside) X.X.1.199
global (outside) X.X.1.200

This allows me to forward ports just for a single IP address between X.X.1.198 and X.X.1.200, except for a problem with SMTP.  Since, when I send out mail via SMTP, the receiver can't come back in the same way, I may have mail rejected.  So, to solve that problem, I need to forward SMTP from X.X.1.198.

Was this correct?
Les MooreSystems Architect
CERTIFIED EXPERT
Top Expert 2008
Commented:
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION

Author

Commented:
Ah, this is starting to make sense - thanks!

So, if I want 3 static IP addresses, how do I add the 3rd IP?
Les MooreSystems Architect
CERTIFIED EXPERT
Top Expert 2008
Commented:
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION

Author

Commented:
Ah!  So I don't have to find some way to assign additional IP addresses to the vLAN - I just use them in the statics and it will work - is that right?

Thanks for all the help!
Les MooreSystems Architect
CERTIFIED EXPERT
Top Expert 2008
Commented:
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION

Author

Commented:
TERRIFIC!  Thanks for all your help!

Gain unlimited access to on-demand training courses with an Experts Exchange subscription.

Get Access
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Empower Your Career
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.