We help IT Professionals succeed at work.
Get Started

corrupted undo tablespace

LJ Gaviola
LJ Gaviola asked
on
1,801 Views
Last Modified: 2008-01-09
hey guys,

i run into a corrupt undo problem and not sure what to do. the databse is still up and running. what i did was:

create a new undo tablespace
set it as as the new undo tablespace
drop the orig tablespace.

but i can't drop the original tablespace, it says  it still says tablespace in use.

and then i was able to take the segments offline but still can't drop the tablespace - i'm getting this error:

ORA-01548 active rollback segment 'string' found, terminate dropping tablespace.

any ideas what to do? I found heaps in the net but not quite sure which one to follow.

urgently need this.

thank you.

Comment
Watch Question
CERTIFIED EXPERT
Top Expert 2008
Commented:
This problem has been solved!
Unlock 2 Answers and 9 Comments.
See Answers
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE