We help IT Professionals succeed at work.

SQL 2000 Reporting Services subscription does not send email, email stays in the pick up directory

mndthegap1
mndthegap1 asked
on
699 Views
Last Modified: 2008-03-17
hello -

im running SQL 2000 on a windows 2003 server.
we have reporting services running and subscriptions seem to be working with 1 small problem. If you go into the subscription it says that the email was sent to the email address successful. But the email is still in the pickup directory. How come the email is not being sent. I have configured an outlook account on the box and send a test email. i went into sql mail used the profile and ran test and came back successful.

does the SMTP service have to be running on the sql server ?what am i missing any help would be greatly appreciated.

here is the section from the rsreportserver.config

</Extension>
<Extension Name="Report Server Email" Type="Microsoft.ReportingServices.EmailDeliveryProvider.EmailProvider,ReportingServicesEmailDeliveryProvider">
<MaxRetries>3</MaxRetries>
<SecondsBeforeRetry>900</SecondsBeforeRetry>
<Configuration>
<RSEmailDPConfiguration>
<SMTPServer>10.1.0.5</SMTPServer>
<SMTPServerPort>25</SMTPServerPort>
<SMTPAccountName>Administrator</SMTPAccountName>
<SMTPConnectionTimeout>30</SMTPConnectionTimeout>
<SMTPServerPickupDirectory>e:\temp</SMTPServerPickupDirectory>
<SMTPUseSSL></SMTPUseSSL>
<SendUsing>1</SendUsing>
<SMTPAuthenticate>0</SMTPAuthenticate>
<From>administrator@argointl.com</From>
<EmbeddedRenderFormats>
<RenderingExtension>MHTML</RenderingExtension>
</EmbeddedRenderFormats>
<PrivilegedUserRenderFormats></PrivilegedUserRenderFormats>
<ExcludedRenderFormats>
<RenderingExtension>HTMLOWC</RenderingExtension>
<RenderingExtension>NULL</RenderingExtension>
</ExcludedRenderFormats>
<SendEmailToUserAlias>True</SendEmailToUserAlias>
<DefaultHostName></DefaultHostName>
<PermittedHosts></PermittedHosts>
</RSEmailDPConfiguration>
</Configuration>
Comment
Watch Question

Author

Commented:
Administrators please delete the following question.
I found the fix.

i needed to install the SMTP service as part of IIS.
once this was done go into the rsconfig file and change the pickup path to poin to the newly created folder in inetpub c:\inetpub\mailroute\pickup

then everything worked.
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.