We help IT Professionals succeed at work.

VPN connection to client works from home but not from office...

204 Views
Last Modified: 2011-09-20
Hi,

A customer gave us VPN access to their network for a new project.  I've been unable to get it working from the office and, on a whim, I tried it from my house and it worked perfectly.  For the life of me, I can't figure out why.

To create the connection, I did Start Menu\Programs\Accessories\Communications\New Connection Wizard and picked all of the default settings for connecting to a work VPN.  (I'm running Win XP Prof at home and at work).

The error that I get from work is:

Disconnected.

 

Error 721: The remote computer did not respond.  For further assistance, click More Info or search Help and Support Center for this error number.

Googling didn't turn up anything that seemed relevant.

Can anyone help?  Thanks so much!
Comment
Watch Question

Commented:
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION

Author

Commented:
Hi Peter, you know I'm not even sure.  I wonder how I could check that?  At home, I have a router and I'm running the Windows firewall, which is turned on, and it works fine.

Commented:
Are you using PPTP or L2TP to connect?  I suppose PPTP...


From your computer at work try the following test from a command prompt:

-If PPTP try:
telnet <IP address of VPN host> 1723

-if L2TP try:
telnet <IP address of VPN host> 1701

if you get connected (a blank screen w/ the cursor blinking in the top right corner) it's probably not your firewall.  If you don't get connected I'd suspect it's either a routing problem or your firewall.  A ping test "should" help you determine whether or not it's a routing problem.

Commented:
Check to see if the VPN IP address you are being assigned is in the same subnet as your office LAN subnet. If they are, that will cause routing problems.

Commented:
>Check to see if the VPN IP address you are being assigned is in the same subnet as your office LAN subnet.

I agree, but in my experience (which isn't worth much!   ;-}    ) it doesn't lead to the connection error MrDeveloper described... The connection will establish itself, but 2nd step problems may present themselves...  often with regard to other hosts on the remote subnet, not so much so connections with the VPN server itself.

none the less, it's a concern that shouldn't be overlooked.

Commented:
Agreed, it should at least connect ...

Commented:
Your firewall at the office needs to support VPN passthrough, sometimes it's an option that you have to turn on.

Commented:
Wow, what a lot of ideas!
One question: do you manage the whole network at work? If not, you'll have to talk to the network manager to configure your VPN acces out.
If you have responsibility for the whole work network, tell us what kit you have between your PC and the internet.
Regards, Peter

Commented:
It appears that either your network or your machine is blocking ports as everyody else has already pointed out,,

This blockage an be on your machine or on the network itself.
To rule out ports blockage n your machine, reboot your machine in safe mode with networking and then try to connect. If you get a successful connection then it is either Windows firewall or some other installed firewall application on your local machine. If however, you do not get a successful connection even in sae mode with networking then your router/firewall device at office is blocking traffic.

Look at article support.microsoft.com/kb/888201
As the article says you would need to open TCP port 1723 and GRE (IP 47) on the firewall. You could show this article to your network admin and get the required ports open.

Cheers!

AJ

Author

Commented:
hey  fhmc ,

In response to your first post, I tried the PPTP telnet and I did indeed get a blank command window with a blinking cursor at the top.

Author

Commented:
1peterx , thanks for your help.  Haha, no I don't manage the network here - what a scary thought.  I do programming and don't know much about networking (In fact, I can see by the great advice here that I know even less than I thought!).

I'm going to try shutting off the firewall and see if that helps.  If not, I'll contact our IT support company to see about the VPN passthrough

Thanks so much for all the great ideas

Author

Commented:
right you were 1peterx , vpn outgoing was blocked by our firewall.  Still working on getting it opened back, but you were 100% right.  Thanks to everyone for all of the great advice!
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.