We help IT Professionals succeed at work.

msizap not working

rockethobbit
rockethobbit asked
on
1,667 Views
Last Modified: 2013-11-14
I am trying to use MSIZAP.exe to remove a program from a bunch of computers. We need the command line version of this, not the GUI to work.

I have tried using it with the product code as well as the MSI file. No go.

I am using the following command line:

MSIZAP TWA! ..... Guid or MSI.... Both no work.

The errors I can see I am getting are:

Unable to open HKEY_USERS hive for user .......
The hire may not be loaded at this time...

I am logged in with someone who has domain admin rights. The documentation said something about loading the profiles? It made it sound like I was to load them before I run the utilitiy? Not familiar with that procedure.

If anyone can help, Much appreciated.

Thanks.
Comment
Watch Question

Author

Commented:
I forgot to mention that I have been able to get this application to be removed, but I used the GUI version "Windows Installer Cleaner." It looks like that program just opens a command prompt and uses MSIZAP from there. I just need to find out what command line parameters the GUI is using so I use them for the command line script.

Thanks.
Technical Writer / Content Manager
Commented:
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION

Author

Commented:
I am using the one that comes with the windows cleaner tool. I downloaded it off of MS site today. So it should be the latest.

I have tried both of the below, but I get the error messages stated in the first post.

msizap TWA! {product code}
msizap TWA! <msi package>
techieblueTechnical Writer / Content Manager
Commented:
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION

Author

Commented:
I have tried to capture the test, but it opens its own cmd prompt and I have paused it at the beginning and I can't see what the command is. It's opening a CMD for the msizap.exe so we can't see what the command is because it runs the command to open the prompt.

Anyone have any ideas?
techieblueTechnical Writer / Content Manager

Commented:
Is it possible that the programs you are trying to remove were installed by the Windows Installer?  because Microsoft claims that those items cannot be removed using this tool:

http://support.microsoft.com/kb/290301

If you are not trying to remove programs installed by the Windows installer, I'll keep working on it, just let me know.
techieblueTechnical Writer / Content Manager

Commented:
I think it could also be a security or rights-related issues.  Since you are logged in as a domain admin, try logging in as a local admin.  See if you can make any headway with that.

Gain unlimited access to on-demand training courses with an Experts Exchange subscription.

Get Access
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Empower Your Career
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.