Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

Troubleshooting
Research
Professional Opinions
Ask a Question
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

troubleshooting Question

New Intel Core 2 Duo iBook will not connect to Belkin router

Avatar of grigorovsky
grigorovsky asked on
Apple Hardware
11 Comments1 Solution507 ViewsLast Modified:
Recently purchased a new Intel Core 2 Duo iBook and have had no problems using it to connect to wireless networks in hotels, airports etc.

The first time I brought it into my office it recognised my Belkin F5D7630-4A router network (homenet) and asked if I wished to join it. At that time I had a 128 bit hex WEP key in place and I duly put this into the Mac. After a few seconds it came back with the message "there was an error joining the airport wireless network homenet".

Repeated attempts failed and even long phone discussions with Mac and Belkin support failed. I have a PC elsewhere in the building which connects wirelessly to the belkin, no problems there and I can connect the iBook using an Ethernet cable.

In desperation I removed the WEP security from the router, leaving a completely open network. Once again the Mac sees it and offers to connect but subsequently throws up the same error message.

I have scoured the net for a solution and have found a number of people with similar problems. In particular an article at: http://www.mac-forums.com/forums/showthread.php?p=308792 seems to reflect a near indentical problem.

Since having this problem I have still been able to connect the Mac wirelessly to Hot Spots etc. in a variety of places.

Any ideas, greatly appreciated.
ASKER CERTIFIED SOLUTION
Avatar of strung
strungFlag of Canada image

Our community of experts have been thoroughly vetted for their expertise and industry experience.

Commented:
This problem has been solved!
Unlock 1 Answer and 11 Comments.
See Answers