Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

Troubleshooting
Research
Professional Opinions
Ask a Question
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

troubleshooting Question

<authentication mode= "none"/"forms"/"windows" /> -still get error:error to use a section registered as allowDefinition='MachineToApplication' beyond application level.This error can be caused

Avatar of jxharding
jxharding asked on
ASP.NET
13 Comments1 Solution3014 ViewsLast Modified:
hi,
IT IS NOT A CASE OF a extra web.config lying in the directory of the web pages.
IT IS NOT A CASE OF the web page not being an application. (mabye i must double check my method)

i have a windows 2003 server. IIS6
we are running a classic asp site from it.
now i made a c# website in asp.net 2005.
the server will now run a classic asp website and my new site.
i installed .net framework 2.0 on windows 2003
i am developing on a XP pro machine with iis 5.1.



Server Error in '/' Application.
--------------------------------------------------------------------------------

Configuration Error
Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level.  This error can be caused by a virtual directory not being configured as an application in IIS.

Source Error:


Line 28:             ASP.NET to identify an incoming user.
Line 29:         -->
Line 30:       <authentication mode="None" />   --      !!!!!!!!--IN RED FONT !!!!!!!!!! THE ERROR POINT TO THIS LINE
Line 31:
Line 32:
 

Source File: C:\Inetpub\wwwroot\mohair\intra\web.config    Line: 30
--------------------------------------------------------------------------------
Version Information: Microsoft .NET Framework Version:2.0.50727.42; ASP.NET Version:2.0.50727.42


--------nothing special in the web.config file:
<?xml version="1.0"?>
<configuration xmlns="http://schemas.microsoft.com/.NetConfiguration/v2.0">
      <appSettings/>
      <connectionStrings>
  <remove name="LocalSqlServer" />
  <add name="cmwConnectionString" connectionString="Data Source=SQLSERVER;Initial Catalog=abc;Persist Security Info=True;User ID=abc;Password=abc"   providerName="System.Data.SqlClient" />
 </connectionStrings>
      <system.web>
            <compilation defaultLanguage="c#" />
            <authentication mode="None" />
      </system.web>
</configuration>


i tried all possible authentication modes
no matter what i make the  authentication mode, i still get the error pointing to line : <authentication mode="None" />


this is what i tried:

right click web sites
new web site
Description Intra


IP ADDRESS AND PORT SETTINGS WIZARD PAGE
Enter IP address to Use for this website:
All unassigned

TCP Port 81 (80 already used by classic asp site)

Host Header :blank


WEBSITE HOME DIRECTORY WIZARD PAGE

BROWSE TO FOLDER WITH FILES: ( i copied them straight from development machines)
web.config
default.aspx
default.aspx.cs

TICKED ALLOW ANONYMOUS ACCESS TO THIS WEBSITE

WEB SITE ACCESS PERMISSIONS
tick READ


now i try to access the web page:
i get the above mentioned error.

now i attempt to make a virtual directory of the website:
right click the intra website -> create new virtual directory.
alias = Intra
browse to same folder
permissons - only read ticked


i still get the same error.

now i right click the virtual directory
properties - virtual director tab-
I click on application name to make it a application.

i still get the same error.


if i now remove the application and make it a virtual directory again, i still get the same error




ASKER CERTIFIED SOLUTION
Avatar of mmarinov
Commented:
This problem has been solved!
Unlock 1 Answer and 13 Comments.
See Answers