We help IT Professionals succeed at work.

"Incorrect syntax near 'GO'" in asp.net application sql2k script

OnlineGuitarist
on
968 Views
Last Modified: 2007-12-19
Hi all,

I have a question, the below sql server script i have running on an asp.net site connected to a sqlserver2k errors out with the following error: "System.Data.SqlClient.SqlException: Line 10: Incorrect syntax near 'GO'."  As a solo programmer from home that does this as a hobby, I think i need a fresh set of eyes on my script as I've scoured through it trying to find out what is wrong.  I'm hardly an intermediate sql2k user so thought maybe if someone could be so kind to review my script below, it would help me fix the other procedures that I'm trying to create as well because they throw the same error.  This is from a dotnetnuke website and the {databaseOwner}[{objectQualifier} string placements should be correct as they work in other parts of my code such as creating the tables.

Any help would be appreciated!

Thx

******************** sql server2k script start********************
create procedure {databaseOwner}[{objectQualifier}CompanyName_GetCredits]

      @ModuleId int

as

SELECT ItemId = {databaseOwner}[{objectQualifier}CompanyName_tblReg].ItemId,
      ModuleId = {databaseOwner}[{objectQualifier}CompanyName_tblReg].ModuleId,
      UserId = {databaseOwner}[{objectQualifier}CompanyName_tblReg].UserId,
      UserCredits = {databaseOwner}[{objectQualifier}CompanyName_tblReg].UserCredits
       
from {databaseOwner}[{objectQualifier}CompanyName_tblReg] with (nolock) left outer join {databaseOwner}Users on {databaseOwner}[{objectQualifier}CompanyName_tblReg].UserId = {databaseOwner}Users.UserId
where  ModuleId = @ModuleId
GO
******************** sql server2k script end********************
Comment
Watch Question

CERTIFIED EXPERT
Most Valuable Expert 2012
Top Expert 2008
Commented:
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION
Guy Hengel [angelIII / a3]Billing Engineer
CERTIFIED EXPERT
Most Valuable Expert 2014
Top Expert 2009
Commented:
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION

Author

Commented:
well, i added return chars after the go command and it worked.  it also worked when i removed the go command.  i preferred the go command, and i found the answer elsewhere, but now i have a better understanding of why this occurred.  apparently, there was no whitespace after the go command, therefore, it ruined my script.

I'll split the points between the two of you because i found the answer elsewhere.

Gain unlimited access to on-demand training courses with an Experts Exchange subscription.

Get Access
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Empower Your Career
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.