We help IT Professionals succeed at work.
Get Started

Cannot assign IP address to ethernet interface, CISCO 871 router

sara_bellum
sara_bellum asked
on
7,097 Views
Last Modified: 2012-06-22
I have been trying to assign IP addresses to the FastEthernet ports on my 871 router via the console interface and I understand that this must be done by defining the address on a vlan interface and then applying the vlan address to the ethernet port.  But it's not working.
I was able to create a "vlan 2" and assign it an ip address:
> Mars(config)#vlan database
> Mars(vlan)#vlan 2 (the space was necessary - both vlan2 and Vlan2 produced this error -
Invalid input detected at '^' marker, under the 2)
> VLAN 2 added:
>    Name: VLAN0002
> Mars(vlan)#exit
> APPLY completed.
> Exiting....
I tried renaming vlan 2 to vlan2 (no space) with the vlan-name command but that too failed.  However I'm happy to accept the default naming conventions if they work.  
My configuration file includes:
> interface Vlan1
> description connection to 2d subnet
> ip address 192.168.1.129 255.255.255.128
> interface Vlan2
> ip address 192.168.1.125 255.255.255.128
and this:
> interface FastEthernet3
> description link to PIX firewall
> switchport access vlan 2
(switchport access Vlan2 produces the same error - Invalid input detected at '^' marker)
Then I tried this:
> Mars(config-if)#int fast 3
> Mars(config-if)#ip address 192.168.1.125 255.255.255.128
and got this error:
% IP addresses may not be configured on L2 links.
I'm stuck, and can find nothing in the CISCO documentation for this type of router that addresses VLAN troubleshooting via the CLI - I guess this is supposed to just work.
I can send the full config file if you need it of course.  So far, only the Vlan1 IP is working -  I can ping it from a laptop connected to the FE 0 port on the router.  The router gives no icmp reply to the Vlan 2 IP from the console port connection (attached to another machine on my LAN) which makes sense because the protocol is down:
Mars#show ip int brief
Interface                  IP-Address      OK? Method Status                Prol
FastEthernet0              unassigned      YES unset  up                    up
FastEthernet1              unassigned      YES unset  up                    down
FastEthernet2              unassigned      YES unset  up                    down
FastEthernet3              unassigned      YES unset  up                    down
FastEthernet4              unassigned      YES NVRAM  administratively down down
Vlan1                      192.168.1.129   YES NVRAM  up                    up
Loopback0                  10.0.1.129      YES NVRAM  up                  up
Vlan2                      192.168.1.125   YES NVRAM  up                    down
How do I bring Vlan2 up, and how do I assign Vlan IP addresses to FE interfaces?
Comment
Watch Question
Instructor
CERTIFIED EXPERT
Top Expert 2015
Commented:
This problem has been solved!
Unlock 2 Answers and 10 Comments.
See Answers
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE