We help IT Professionals succeed at work.

Vb to Mysql Connection takes 16 seconds from local network

Cem Türk
Cem Türk asked
on
360 Views
Last Modified: 2008-01-09
i have installed mysql on Windows 2003 Server and when i try to connect from vb to mysql from the machine itself connects instantly, but when i try to connect  from another machine in the network it takes 16 seconds to connect. It takes 16 seconds to connect from the Internet.

I have tried to connect via windows Data resources (ODBC) the same thing happened.

I am using MySQL ODBC 3.51 Driver to connect. I think i need to make a few configuration changes, but i dont know what to change.

(I have tried both Rdo and Ado connection and the result is the same)

Please help me to reduce the connection time.

Thanks
Comment
Watch Question

i use mysql and don't see this problems
but i got rid of ODBC and use the OLE .net connector
which is available in on www.mysql.com web site

good luck
greg
i use CoreLab (www.crlab.com), which offers a very fine top of the line native .NET mysql connector that supports even tableadapters and typed datasets if you use vb2005.

NY

Commented:
Hit up www.connectionStrings.com for different connection strings, maybe that would help.
http://www.connectionstrings.com/?carrier=mysql
Cem TürkSenior Software Engineer

Author

Commented:
thanks for your replies, i am using VB 6.0 in this project, so any .NET solution will not work for me, i have tried different connection strings as well. I think the main reason for the delay is not the code part, it must be something with network settings or etc. i have tried to change lots of things but was not successful.
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION
Cem TürkSenior Software Engineer

Author

Commented:
i have tried that... no success...
We should try to narrow down the problem.  Try connecting with the command-line client to see if the same problem occurs:

mysql --host=<server_name> --user=<username> --password=<password>

This will tell us if the problem is with your connectors.


--Adrian
Cem TürkSenior Software Engineer

Author

Commented:
mysql was installed as a service, i was trying to add --skip-name-resolve as a parameter from services... first it did not work... today i tried it from command line it succeeded and i have reinstalled mysql with the new parameter.

 thanks to everyone!
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.