We help IT Professionals succeed at work.
Get Started

DHCP problems.

farfo
farfo asked
on
4,794 Views
Last Modified: 2007-12-19
We've been having intermittent issues with WinXP clients and slow DHCP.

The pattern with regard to which clients are affected seems pretty random.
Things can be fine for a couple of days, then a handful of clients will be hit by
slow DHCP again- displaying a "Limited or no connectivity" icon for up to 30 seconds.

The disruption to network connectivity at logon affects GPO processing (e.g. logon scripts
applied by GPO fail to run), and affected users are required to log off, then back on again
to get their network drives etc.

Setting a static IP on affected clients also resolves all problems.  

We have:
- a 192.168.0.* network.  
- W2K3 server.  DHCP runs on a D.C.
- Win XP SP2 clients.
- Cisco Catalyst 3500 Switches


The errors in XP client Event logs include:
--------------------------------------------------

1) Source: Userenv
Event ID: 1054
Windows cannot obtain the domain controller name for your computer network. (The specified domain
either does not exist or could not be contacted. ). Group Policy processing aborted.


2) Source: userinit
Event ID: 1000
Description:

Could not execute the following script Logon.vbs. The system cannot find the file specified.


3) Source: DHCP
Event ID: 1007
Type: Warning

Description:
Your computer has automatically configured the IP address for the Network card with network address
XXXXXXXXXXXX.  The IP address being used is 169.254.57.55


4) Source: DNSApi
EventID: 11191
Type: Warning

Description:
The system failed to update and remove pointer (PTR) resource records (RRs) for network adapter
with settings:

   Adapter Name : {XXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX}
   Host Name : XXXX
   Adapter-specific Domain Suffix : company.local
   DNS server list :
           192.168.0.X, 192.168.0.Y
   Sent update to server : <?>
   IP Address : 192.1.1.1

 The system could not remove these PTR RRs because because of a system problem. For specific error code, see the record data displayed below.


5) Source DHCP
EventID: 1002
Type: Error

Description:

The IP Address lease 192.168.1.12 for the network card with network address XXXXXXXXXX has been
denied by the DHCP server 192.168.0.X (the DHCP server sent a DHCPNACK message).

-------------------------------------------

With 3) above it's weird- the client will display a 192.168.0.* address when I run ipconfig on it-
not an APIPA address as indicated.

4) and 5) are also strange given our network is a 192.168.0.*

Any ideas?  I'm concerned about possible rogue servers or ICS on the network (some of our users get a
bit "creative" occasionally)- but a second opinion / confirmation  would be great.

I've already tried the following without any luck:
      - Applying the "Always wait for the network at computer startup.." GPO setting
      - Disabling Spanning Tree protocol on the Switches:             
      http://support.microsoft.com/default.aspx?scid=kb;en-us;Q168455

Thanks,
Farfo.
Comment
Watch Question
This problem has been solved!
Unlock 2 Answers and 2 Comments.
See Answers
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE