Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

Troubleshooting
Research
Professional Opinions
Ask a Question
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

troubleshooting Question

Sqlcmd: Error: SQL Server does not allow remote connections

Avatar of FredZimmerman
FredZimmerman asked on
Microsoft SQL Server
2 Comments1 Solution2604 ViewsLast Modified:
I have just installed SQL Server 2005 Developer Ed. on Win XP.

I have changed th SQL Server instance name to MSSQL (I see MSSQL$MSSQL in the configuration console for the SQL Server instance).

I have enabled Remote connections in configuration with Named Pipes and TCP for local or remote connections.

When I load a DOS command window and type: Sqlcmd   <enter>

I get following error message:

C:\Documents and Settings\Fred>sqlcmd -S MSSQL -H PENTIUM -U fred -P fredz357
HResult 0x35, Level 16, State 1
Named Pipes Provider: Could not open a connection to SQL Server [53].
Sqlcmd: Error: Microsoft SQL Native Client : An error has occurred while establi
shing a connection to the server. When connecting to SQL Server 2005, this failu
re may be caused by the fact that under the default settings SQL Server does not
 allow remote connections..
Sqlcmd: Error: Microsoft SQL Native Client : Login timeout expired.

Any ideas or helpful suggestions to remedy this?  I could not get answer from prior similar
questions/responses to E-E.

Fred Z.
ASKER CERTIFIED SOLUTION
Avatar of nmcdermaid
nmcdermaid

Our community of experts have been thoroughly vetted for their expertise and industry experience.

Commented:
This problem has been solved!
Unlock 1 Answer and 2 Comments.
See Answers