Link to home
Start Free TrialLog in
Avatar of gwardlaw

asked on

limited or no connectivity

I am getting the "limited or no connectivity" message on a desktop connected (wired) to a dsl modem and router. I have tried a new network card, put the card in another slot. installed new drivers, and tried the usb connection. I have flashed the bios also. The trick is I have two laptops connecting to the router wirelessly with no problems. I have went through the check list at "PChell" and nothing has worked. I can connect to a couple web sites and then I lose connectivity. I can restart pc and same issue. I have changed patch cables as well. The problem is obviously on the desktop pc, but I am out of ideas.
Avatar of AndyJG247
Flag of United Kingdom of Great Britain and Northern Ireland image

the usb and the nic both seperately work and then show disconnected after a few webpages?
Just wanted to clear it in my mind
Avatar of static-void

doesnt sound like your dhcp server is enabled for your wired network to me....
As you checked in PCHell, below are few more. Have you run program to fix the winsock yet?

Everytime you boot you loose connection after a few websites?  You loose your ip address as in you get or a 169. address?  try hardcoding an ip address yet?
have you tried plugging computer directly into model?  

Who is you ISP?

What is the model of your DSL modem?

if you want to setup a router behind it you need to modify the dsl modem as passthrough so all login and DHCP occur on router


I assume that the dsl modem uses network

you can change your network on your router to network which whoul allow them work seamlessly.

I could tell more once you answer mine the previous questions
Avatar of zceororlo

Link to home
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of gwardlaw


When I looked to make sure the DHCP service was running I saw a strange service running at the bottom of the list. I googled it and it was a worm. Spybot and adaware had missed it. I ran the product formerly Ewido and followed instructions for removal and that fixed the problem. Thanks.
what was that service called? I had the same problem recently, my computer was firewalled, has been used on several networks without any hint of a problem with accepting DHCP and all of a sudden a few weeks ago, on a Veryyy trusted network (my own!) I ran into a brick wall, my laptop no longer accepted an IP. I tried everything from the router side, I tried all these crazy fixes for winsock and that produced nothing, I had tried ipconfig (which I've used 100s of time successfully in the past) and neither /release /renew would resolve the issue - it was a dead end - I ended up reinstalling the OS (didn't lose any info, I partition my laptop ;))

I'm curious as to what service you found running in your system.