Link to home
Start Free TrialLog in
Avatar of edwalters
edwalters

asked on

RPC/HTTP Exchange 2003.

Using RPC/HTTP Exchange 2003.  If I do https:\\mail.domain.com/rpc on the network it returns a blank page with a link to parent directory and rpcproxy.dll.
Our OMA and OWA settings work fine using a third party trusted certificate, so I don't see why the RPC isn't working as well.  We have completed all the registry edits etc.
Outlook works internally if you set it to use HTTP but I assume that is because it resolves it back to the name of the internal mail server.
Avatar of Sembee
Sembee
Flag of United Kingdom of Great Britain and Northern Ireland image

That shouldn't happen.
You should get an authentication prompt then an error message.

I would suggest removing the rpc proxy component from Windows Components, then removing the /rpc and rpcwithcert directories in IIS manager. Then run iisreset to write the changes to the metabase.
Once done, reinstall the RPC Proxy component. Don't touch the virtual folder configuration and try again.

Simon.
Avatar of edwalters
edwalters

ASKER

Thanks for that, it seems to have moved things on a little.  i now seem to be getting a permissions type error though.

I enter  https:\\ex1.domainname.com/rpc  and I get challenged for a username and password.

I enter domainname\myname and the password, it make me do this three times then fails with a "You are not authorized to view this page"  It then goes on to talk about access control lists.  I'm not sure what I have done to make htis so dificult, OWA and OMA worked fine straight away.

Any help would be very helpfull.

Ed
You will always get an error when connecting to /rpc with a web browser. It is used as a check for certificate acceptance. If you browse to the URL and get a certificate prompt then the feature will not work as Outlook cannot cope with any certificate prompts.

Presuming that you have made the registry settings, I would suggest trying to use Outlook now.

Configure Outlook in the usual way and confirm that it connects. Then add the RPC over HTTPS settings, without touching the regular settings.

Restart Outlook and use the rpcdiag switch to confirm if connectivity is being made over https (outlook.exe /rpcdiag).

Simon.
Thanks.. I seem to have it working internally and I can see that it is connecting using HTTPS in Outlook /rpcdiag.  However it doesn't seem to be working externally, it keeps throwing up the login box even though the domain\unsername etc is being entered.  Although to be fair someone else is testing it ecternally so I can't confirm what he is doing.

Thanks for you help on this,
ASKER CERTIFIED SOLUTION
Avatar of Sembee
Sembee
Flag of United Kingdom of Great Britain and Northern Ireland image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Thanks I think it might be there now, I'm just waiting for confirmation.
In total I did what you said about uninstalling the RPC component, then deleting the Virtual Directories, did IISRESET reinstalled the RPC component then ran the registry tool RPCNOFRONTEND to configure the registry.
After that the internal HTTPS worked and I'm hoping to get confirmation of the external one as well.
Many thanks for all your help.  I think I may be contacting you about your consultancy at a later date as well.

Cheers

Ed