troubleshooting Question

2 isp's one router

Avatar of it_gsr
it_gsr asked on
Routers
5 Comments1 Solution2060 ViewsLast Modified:
Site A has two internet connections from two isp’s and one router. The router is   Cisco 1700 series connected to a PIX 515e. Site A has an MPLS connection from ISP 1 to Site B which also acts as it’s internet connection. The source of ISP1’s internet is at site B. Site A  has two ethernet interfaces. The Fast0 is connected to  the MPLS link from ISP 1 whiles ethernet0 is connected to ISP 2. ISP 2 connection is via VSAT on the serial interface. We would like to create a failover situation at site A so that if the MPLS link fails, the system should be able to switch to the VSAT
for internet at Site A.


The config below only works if the weight on the default route on the serial0 is manually increased to the same level as the default route on 10.20.20.9. and the gateway on the Domain controller acting as DHCP is changed to the internal IP of the firewall.
How can the router's config made to work automatically without any manual intervention
 





Building configuration...

Current configuration : 957 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname XXXX
!
enable secret 5 $1$eLc/$3HMpM7vIesR8cH2dyXJ0k/
enable password ****
!
ip subnet-zero
ip name-server isp1
ip name-server isp1
ip name-server isp2
!
!
!
!
interface Ethernet0
 ip address A.B.C.D 255.255.255.248
 full-duplex
!
interface FastEthernet0
 ip address 10.20.20.10 255.255.255.252 secondary
 ip address 172.16.16.2 255.255.240.0
 speed auto
!
interface Serial0
 description Link to Internet
 ip address E.F.G.H 255.255.255.254
 no keepalive
 no fair-queue
 ignore-dcd
 down-when-looped
 no cdp enable
!
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0 2
ip route 0.0.0.0 0.0.0.0 10.20.20.9
no ip http server
!
!
snmp-server community public ****
!
line con 0
line aux 0
line vty 0 4
 password *******
 login
!
no scheduler allocate
end
ASKER CERTIFIED SOLUTION
Les Moore
Systems Architect

Our community of experts have been thoroughly vetted for their expertise and industry experience.

Top Expert 2008

The Distinguished Expert awards are presented to the top veteran and rookie experts to earn the most points in the top 50 topics.

Log in to continue reading
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform for $9.99/mo
View membership options
Unlock 1 Answer and 5 Comments.
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
See how we're fighting big data
The Value of Experts Exchange in My Daily IT Life

Experts Exchange (EE) has become my company's go-to resource to get answers. I've used EE to make decisions, solve problems and even save customers. OutagesIO has been a challenging project and... Keep reading >>

Mike

Owner of Outages.IO
Phoenix, Arizona, United States
Member Since 2016
Join a full scale community that combines the best parts of other tools into one platform.
Unlock 1 Answer and 5 Comments.
View membership options
“All of life is about relationships, and EE has made a virtual community a real community. It lifts everyone's boat.”
William Peck

Member since 2004