Link to home
Avatar of Lance_P
Lance_P

asked on

Exchange SBS 2003. Https will not work. http works fine.

I have installed Win SBS 2003. Everything seems to be working fine. I need to configure OWA to use https. But im unable to do so.
  I can connect using http just fine. When i change the settings for exchange to use https, i get page cannot be displayed. While the setting is on and i try to connect using http, i get the required message which says you need to connect using https:// .... There is no other program using port 443.
  What could be the possible cause. Detailed info provided will be of great assistance.
  I have gone through some solutions found online.. but it just wont work. For the time being i have asked clients to use pop which works like a charm. (when connecting from outside).
Avatar of Michael S
Michael S
Flag of United States of America image

How did you change the settings to use HTTPS?  SBS is wizard-driven, so if you make any changes it's best to use the wizards, especially when setting up SSL connections.

If you use the Wizard and you still have problems, it's normally an IIS VD problem.
Avatar of Lance_P
Lance_P

ASKER

Frankly i used the wizard during the setup. Thats it. No wizards after that. Im kinda new to this too. I tried to follow a doc and went through the entire procedure of making a secure certificate nogo.

Another thing i need to point out. I tried running the default website in https mode. I enabled user authntication for the se same. I get a pop up to access the webpage and then 'bang' page cannot be displayed.. Im wondering if its gotta have something to do with 443..

Avatar of Lance_P

ASKER

Is there any way i can re run the wizard without affecting the settings and mails.
You can run the wizard at any time - it will stop and restart the services so you might have to do it after hours, but yes.
Simple rule with SBS - run the wizard.
When you run the wizard you get options about not changing certain things. Connection settings and email settings are two that can be skipped in the wizard.

Simon.
Avatar of Lance_P

ASKER

Where do i run the wizard from? CD? Any place you could direct me to? Shortcut path ..? I dont wanna mess up the mails.. Daily backups are taken .. But thats not an option for now.

Thanks for the help in advance.
Click Start, and then click Server Management.  In the console tree, click Internet and E-mail. In the details pane, click Connect to the Internet. The Configure E-mail and Internet Connection Wizard (CEICW) appears.
 
Avatar of Lance_P

ASKER

Thanks guys.  Will try that in a couple of hours and then get back to ya.
Avatar of Lance_P

ASKER

OK. 1 small problem. This server that im trying to configure, is not SBS.
It has Windows 2003 server Standard and Exchange 2003 Standard. Where can i find the Inter and Email wizard for this?

I think i remember cancelling out of the wizard during setup during installation. :(
Avatar of Lance_P

ASKER

Even the default website will not run in https mode... Seems like its a problem with the https protocol or the 443 port more than anything else.
Avatar of Lance_P

ASKER

I cannot access it internally or externally when using the https protocol. Niether on the server.
In your question title you put "Exchange SBS 2003".
Now you say you are not running SBS?

Are you sure that you know what you are running?

We can only work on what information you provide. If someone says that they are running SBS then we have to presume that they are correct.

Simon.
Avatar of Lance_P

ASKER

Sorry about that sembee.. This installation was done by me a couple of months back. And the only non SBS installation. Probably thats why i cannot get this to work. I crosschecked the SBS anyways and found the wizard. Works like a charm there.

Only here i seem to have run in a road block. Cannot access exchange on https.. :(
I did follow a doc which walked me through issunig a certificate etc and then enabling https.. but that did not work. Tried running the website on https.. that too comes up with page cannot be displayed directly.


ASKER CERTIFIED SOLUTION
Avatar of Sembee
Sembee
Flag of United Kingdom of Great Britain and Northern Ireland image

Blurred text
THIS SOLUTION IS ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
Avatar of Lance_P

ASKER

The genius rank is definetly justified. Thanks Simon.

Thanks Jay i guess i goofed up in the question..

Simon if the question can be edited then nothing like it. Else other users will miss out on this one.