Link to home
Start Free TrialLog in
Avatar of CWilbourne
CWilbourne

asked on

Home Drive Mapping Intermittent Failure - XP SP2 clients on 2003 Domain

Hi,
I asked this question some time ago but never received any responses, so, as it's still a problem and others too seem to be suffering from it (look on google groups) I though I'd re-post it.....
We use the usual single "Root" share containing all our users home directories and define the mapped drive in AD (win2K3 domain) as \\<server>\home\%USERNAME% (where home is the actual sharename on the server).
 On Win2K and XP SP1 clients this is fine the drive maps correctly every time the user logs in, BUT on XP SP2 the drive is intermittently mapped incorrectly. When it maps wrongly, the HOMESHARE  and HOMEPATH variables are incorrect - in fact exactly as they used to be in NT4 (HOMESHARE = \\servername\home and HOMEPATH = \%username%) When it maps correctly ithey're "\\servername\home\%username%" and "\" respectively.
I've tried mapping the drive in a LogonScript called by GPO AND defined in the users profile in AD all with the same result. I have also set the option in GPO to force the Win2k "deep mapping" and this has made no difference.

Any help/ideas would be greatly appreciated.

Cheers,

Chris
Avatar of and235100
and235100
Flag of United Kingdom of Great Britain and Northern Ireland image

Check whether your GPOs are beeing applied properly.

Log on to one of the SP2 stations, and from a command line, run gpupdate /force

Reboot (if required) - and check if the mappings return.
Avatar of CWilbourne
CWilbourne

ASKER

Thanks for your response, I've actually already tried this AND also run RSOP on the SP2 machine(s) to see if the resulting policy is correct "Connect home drive to the root of the share" option is DISABLED and it is and also that "Group Policy Slow link detection" is effectively disabled (it is) so I'm still at a loss....
At last I have found how to solve this......

There is an option in GPO "Always wait for the network at computer startup and logon" under Computer Settings->Administrative Templates->System->Logon

Once this is enabled, the home directories start to map correctly.

Excellent - glad your problem is now resolved.

If you have answered the question yourself - post a new question in the Community Support TA, containing a link to this question, with a request to close and PAQ it.

I have no problems with this being closed and points being refunded.
ASKER CERTIFIED SOLUTION
Avatar of kodiakbear
kodiakbear

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
I just paid to see the solution to this problem........ 60$ for this... pfff

h**ly sh*t !!!
cndfsti,
The solution I found (for myself) is in the thread - if you're still having problems with this  let me know I may be able to help further....