troubleshooting Question

Cisco 1841 - VPN Request forwarding to Server (Port 1723) Issue

Avatar of jforville
jforville asked on
RoutersNetworkingVPN
6 Comments1 Solution549 ViewsLast Modified:
I need some help with my NEW Cisco 1841.  I have successfully setup the router and have internet access etc.  My next step is to get VPN access.  So thus far, I have setup a VPN connection (to the public IP of the router) on the remote desktop PC.  I would like to simple pass VPN request to my Windows Server (Private IP) which is running Routing and Remote access.  I have allowed GRE and Port 1723 (tcp & udp) thru my firewall.  My problem is that I don't know how to forward the traffic.  I tried NAT and I can't get it to work.  Can some please advize?  I have beed using the SDM interface for my changes.  Also, how do you perform a "clear xlate" from the SDM?

Thank you for any help - Tony


Building configuration...

Current configuration : 10088 bytes
!
version 12.4
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service sequence-numbers
!
hostname CPDSU-Samworth
!
boot-start-marker
boot-end-marker
!
security authentication failure rate 3 log
security passwords min-length 6
logging buffered 51200 debugging
logging console critical
enable secret 5 $1$U1a3$vsbiPnJ.cQXQ74JPlB07E.
!
aaa new-model
!
!
aaa authentication login default local
aaa authorization exec default local
!
aaa session-id common
!
resource policy
!
clock timezone PCTime -5
clock summer-time PCTime date Apr 6 2003 2:00 Oct 26 2003 2:00
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
no ip source-route
ip cef
!
!
ip inspect name DEFAULT100 cuseeme
ip inspect name DEFAULT100 ftp
ip inspect name DEFAULT100 h323
ip inspect name DEFAULT100 icmp
ip inspect name DEFAULT100 netshow
ip inspect name DEFAULT100 rcmd
ip inspect name DEFAULT100 realaudio
ip inspect name DEFAULT100 rtsp
ip inspect name DEFAULT100 esmtp
ip inspect name DEFAULT100 sqlnet
ip inspect name DEFAULT100 streamworks
ip inspect name DEFAULT100 tftp
ip inspect name DEFAULT100 tcp
ip inspect name DEFAULT100 udp
ip inspect name DEFAULT100 vdolive
ip inspect name SDM_LOW cuseeme
ip inspect name SDM_LOW dns
ip inspect name SDM_LOW ftp
ip inspect name SDM_LOW h323
ip inspect name SDM_LOW https
ip inspect name SDM_LOW icmp
ip inspect name SDM_LOW imap
ip inspect name SDM_LOW pop3
ip inspect name SDM_LOW netshow
ip inspect name SDM_LOW rcmd
ip inspect name SDM_LOW realaudio
ip inspect name SDM_LOW rtsp
ip inspect name SDM_LOW esmtp
ip inspect name SDM_LOW sqlnet
ip inspect name SDM_LOW streamworks
ip inspect name SDM_LOW tftp
ip inspect name SDM_LOW tcp
ip inspect name SDM_LOW udp
ip inspect name SDM_LOW vdolive
ip tcp synwait-time 10
!
!
no ip bootp server
ip domain name compasspharma.com
ip name-server *
ip name-server *
ip ssh time-out 60
ip ssh authentication-retries 2
!
interface FastEthernet0/0
 description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0$$FW_OUTSIDE$
 ip address 10.10.10.1 255.255.255.248
 shutdown
 ip access-group 102 in
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip inspect SDM_LOW in
 ip nat inside
 ip virtual-reassembly
 ip route-cache flow
 duplex auto
 speed auto
 no mop enabled
!
interface FastEthernet0/1
 description $ES_LAN$$FW_INSIDE$
 ip address 192.168.77.254 255.255.255.0
 ip access-group 104 in
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip nat inside
 ip virtual-reassembly
 ip route-cache flow
 duplex auto
 speed auto
 no mop enabled
!
interface Serial0/0/0
 description $ES_WAN$$FW_OUTSIDE$
 no ip address
 ip verify unicast reverse-path
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip inspect DEFAULT100 out
 ip nat outside
 ip virtual-reassembly
 encapsulation frame-relay IETF
 ip route-cache flow
 service-module t1 timeslots 1-24
 frame-relay lmi-type ansi
!
interface Serial0/0/0.1 point-to-point
 description $FW_OUTSIDE$
 ip address * 255.255.255.248
 ip access-group 105 in
 ip verify unicast reverse-path
 ip inspect SDM_LOW out
 ip nat outside
 ip virtual-reassembly
 no cdp enable
 frame-relay interface-dlci 44  
 crypto map SDM_CMAP_1
!
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0/0/0.1
!
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip nat inside source route-map SDM_RMAP_1 interface Serial0/0/0.1 overload
!
ip access-list extended sdm_serial0/0/0.1_in
 remark SDM_ACL Category=1
 remark VPN
 permit tcp any host 192.168.77.1 eq 1723
!
logging trap debugging
access-list 1 remark INSIDE_IF=FastEthernet0/1
access-list 1 remark SDM_ACL Category=2
access-list 1 permit 192.168.77.0 0.0.0.255
access-list 2 remark SDM_ACL Category=1
access-list 2 permit 192.168.77.1
access-list 100 remark auto generated by Cisco SDM Express firewall configuration
access-list 100 remark SDM_ACL Category=1
access-list 100 permit ip any any
access-list 101 remark auto generated by Cisco SDM Express firewall configuration
access-list 101 remark SDM_ACL Category=1
access-list 101 permit udp host * eq domain host *
access-list 101 permit udp host * eq domain host *
access-list 101 deny   ip 192.168.77.0 0.0.0.255 any
access-list 101 permit icmp any host * echo-reply
access-list 101 permit icmp any host * time-exceeded
access-list 101 permit icmp any host * unreachable
access-list 101 deny   ip 10.0.0.0 0.255.255.255 any
access-list 101 deny   ip 172.16.0.0 0.15.255.255 any
access-list 101 deny   ip 192.168.0.0 0.0.255.255 any
access-list 101 deny   ip 127.0.0.0 0.255.255.255 any
access-list 101 deny   ip host 255.255.255.255 any
access-list 101 deny   ip host 0.0.0.0 any
access-list 101 deny   ip any any
access-list 102 remark auto generated by SDM firewall configuration
access-list 102 remark SDM_ACL Category=1
access-list 102 permit ip any any
access-list 103 remark auto generated by SDM firewall configuration
access-list 103 remark SDM_ACL Category=1
access-list 103 deny   ip * 0.0.0.7 any
access-list 103 permit icmp any host 10.10.10.1 echo-reply
access-list 103 permit icmp any host 10.10.10.1 time-exceeded
access-list 103 permit icmp any host 10.10.10.1 unreachable
access-list 103 deny   ip 10.0.0.0 0.255.255.255 any
access-list 103 deny   ip 172.16.0.0 0.15.255.255 any
access-list 103 deny   ip 192.168.0.0 0.0.255.255 any
access-list 103 deny   ip 127.0.0.0 0.255.255.255 any
access-list 103 deny   ip host 255.255.255.255 any
access-list 103 deny   ip host 0.0.0.0 any
access-list 103 deny   ip any any log
access-list 104 remark auto generated by SDM firewall configuration
access-list 104 remark SDM_ACL Category=1
access-list 104 permit udp host 192.168.77.1 eq 1645 host 192.168.77.254
access-list 104 permit udp host 192.168.77.1 eq 1646 host 192.168.77.254
access-list 104 deny   ip 67.158.127.104 0.0.0.7 any
access-list 104 deny   ip host 255.255.255.255 any
access-list 104 deny   ip 127.0.0.0 0.255.255.255 any
access-list 104 permit ip any any
access-list 105 remark auto generated by SDM firewall configuration
access-list 105 remark SDM_ACL Category=1
access-list 105 deny   icmp any host 67.158.127.105 echo-reply
access-list 105 remark VPN
access-list 105 permit tcp any eq 1723 host * eq 1723
access-list 105 remark VPN
access-list 105 permit udp any eq 1723 host * eq 1723
access-list 105 remark VPN
access-list 105 permit gre any host *
access-list 105 permit icmp any host * time-exceeded
access-list 105 permit icmp any host * unreachable
access-list 105 permit tcp any host * eq 443
access-list 105 permit tcp any eq www host * eq www
access-list 105 permit tcp any host * eq 22
access-list 105 permit tcp any host * eq cmd
access-list 106 remark SDM_ACL Category=4
access-list 106 remark IPSec Rule
access-list 106 permit ip 192.168.77.0 0.0.0.255 192.168.78.0 0.0.0.255
access-list 107 remark SDM_ACL Category=2
access-list 107 remark IPSec Rule
access-list 107 deny   ip 192.168.77.0 0.0.0.255 192.168.78.0 0.0.0.255
access-list 107 permit ip 192.168.77.0 0.0.0.255 any
no cdp run
route-map SDM_RMAP_1 permit 1
 match ip address 107
!
control-plane
!
banner login ^CCCAuthorized access only!
 Disconnect IMMEDIATELY if you are not an authorized user!^C
!
line con 0
 transport output telnet
line aux 0
 transport output telnet
line vty 0 4
 transport input telnet ssh
line vty 5 15
 transport input telnet ssh
!
scheduler allocate 4000 1000
end
Join the community to see this answer!
Join our exclusive community to see this answer & millions of others.
Unlock 1 Answer and 6 Comments.
Join the Community
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 1 Answer and 6 Comments.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros