Link to home
Start Free TrialLog in
Avatar of Yaniv Schiff
Yaniv SchiffFlag for United States of America

asked on

can't boot ghost imaged drive, only get a blinking cursor

I am having a problem getting an Ghost Imaged drive to boot.

I have created a base image for my HP NX9420 Laptop with Windows XP Pro SP2. Normally this machine 2 partitions, a D partition which is the HP_Recovery, and a C partition which is the boot partition for Windows. I used the HP delete partition wizard to blow away the D partition so now i'm just left with the C partition. I also ran sysprep before imaging the drive.

I created an Image of this drive using Ghost v. 8. I imaged it two ways, i imaged the drive and i also imaged the partition.

I then pushed out this image to a new hard drive by using Image to Disk and also Partition to Disk.

When i try booting up the original disk it works just fine. Both in the original machine and in another but same machine.

When i try booting up the new drive all i get after the bios splash screen is a blinking cursor in the upper left hand corner. This happens on the new machine and on the original machine.
I assume this has something to do with the machine not being able to find the boot partition or something along those lines but i can't figure out why.

If anyone could help me out with this i would greatly appreciate it. I have been struggling with this problem for sometime now and would like to get it resolved once and for all.
Avatar of timeshell

Link to home
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of Yaniv Schiff


i tried using Freedos

at the command prompt i typed in "fdisk /mbr", i then rebooted the machine and still get the blinking cursor and nothing more.

I also tried typing in "fdisk /mbr -c:" and "fdisk /mbr -c" because i i thought i might have to designate the drive i wanted to fix. Both these returned a syntax error. What am i doing wrong?
Link to home
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
The new machine is EXACTLY the same as the ghosted machine.

I have already done a disk to disk image, only get the blinking cursor.
If you put back original drive in old machine is is it boots fine? if so, hook up new drive on that system as slave drive and do image disk to disk again. It will work.
The problem with that PUNKY is that this is a laptop so i will have to hook the slave drive up via usb, which i can do, but why will doing a disk to disk image on the original device will be different than doing a disk to disk using our ghost server?
Disk to disk is more reliable in my opinion, though. I did a lot of before, so I am confident that will work for you. Try that.

Please post back.
I did what you recommended. Still getting the same result. Any other suggestions?
The original disk boots fine?
Avatar of timeshell

I had the same problem with an IBM Thinkpad.  The problem was that the Thinkpad has a larger MBR than standard preventing a straight ghost from working.   Doing the fdisk /mbr restored the MBR that the computer was expecting.  This was the only solution that worked for me after many different attempts to restore, whether by partition to partition, image file to disk, disk to disk, etc.

The original boots fine

when you do the fdisk /mbr what is the exact command you type in. I did it booting off the the FreeDOS live CD.
I simply did fdisk /mbr from the FreeDOS Live CD as well.

Here is a link describing how to do it from a Windows Restore session that may wish to try also.

I'm trying to find my previous notes from when I did this.  I'll let you know if I find more info.
You may want to look at this MBR Wizard as well.
As another thought (as I'm still groping my memories for steps I did to fix this), you may want to try hiding or unhiding the utility partition and doing fdisk /mbr again.  If memory serves, it may have something to do with whether or not it was hidden at the time.
what do you mean by the utility partition?
On the Thinkpad there was a hidden utility partition that contained restore information and computer settings.  I believe that HP/Compaq also use this EISA partition as well.  I cannot tell you for sure if this applies or not, but you may wish to check the BIOS settings to see if there is a way to make it visible.
We are talking about HP, aren't we? but Timeshell is right, hidden partition could be a problem. There should be an option in bios to set hide or unhide this. Try, please.
The concept is still the same PUNKY.  I know that there are several different manufacturers that use this extended MBR approach on their notebooks.  Why is another question.  But I am 98% sure this is the issue as I had the exact same symptoms when I was doing a clone on a Thinkpad T42.
Try ruling out Ghost,  use another imaging software.
a Linux boot disk with disk imaging:
There is a setting in newer versions of ghost -IB which is supposed to copy the MBR.  You may want to try that.  It didn't work for me.

Although I don't want to rule out it's possibility of working, I doubt a different imaging software will help unless it specifically copies the original MBR.
You guys are right in that there was a hidden utility partition. But i deleted it before i made my first image so that i only had one partition.

The good news is is that i finally got it to work. I colleague of mine recommended i try restoring the image of the network and viola, it worked beautifully. I have absolutely no idea what the difference is by doing it over the network rather than a direct connect but apperantly there is. If any of you guys can think of what changes i would love to know.

Also, i'm going to try out those other imagin programs ednetman recommended just out of curiosity.

Oh, one other thing. We used to do all of our imagin over the network but then a while back ago, out of the blue, whenever we try to do it over the network we only get around 20Mbps data transfer. We're running gigabit here so we should be getting much much more. Any one have any ideas? I know this is kind-of diverging from the original topic, just thought i would throw it out there.

Even though know one really solved my problem i appreciate all the help so i'll divvy up the points later.

Thanks again.
Restoring over the network forces the notebook to create the MBR rather than the imaging software.